Support » Plugin: WordPress HTTPS (SSL) » [Plugin: WordPress HTTPS] bloginfo http/https on "Disable Automatic HTTPS"

  • Resolved hatkyinc


    1st of all thanks for the plugin.

    Yes I have one of these not all elements on https.
    I think I have found a small problem.

    When setting “Disable Automatic HTTPS” on.

    The bloginfo and get_bloginfo commands are set to http.

    Now this is partially right and partially wrong.

    Because for example my Theme uses bloginfo’s “stylesheet_url” which of course is a css file that should be vie https on an https page.
    And also “template_directory”.

    And why is this partially right and I understand we can see it the other way – wpurl should be http and not https as this option is set.

    So actually in this filter we should go more in dept and decide on each parameter separately.

    I could be wrong, but that’s my 2cents after debugging my own problem.
    (if I am right and it is fixed maybe you will have less support tickets 😉 )

Viewing 3 replies - 1 through 3 (of 3 total)
  • hatkyinc


    ops, nvm I was wrong somehow the problem is elsewhere

    Plugin Author Mike Ems


    I’m glad you got it fixed, but it is worth noting that the bloginfo and get_bloginfo functions’ output is filtered by my plugin when using a few different options. Here is the function from my plugin with which I filter the bloginfo and get_bloginfo functions.

    function bloginfo($result = '', $show = '') {
       if ($show == 'stylesheet_url' || $show == 'template_url' || $show == 'wpurl' || $show == 'home' || $show == 'siteurl' || $show == 'url') {
        $result = $this->replace_https($result);
       return $result;

    This removes HTTPS from URL’s when the ‘Disable Automatic HTTPS’ option is enabled, the page is HTTPS, and the site URL is not set to a HTTPS address.

    However, when the plugin comes back around and fixes all the elements on the page, it’s smart enough to fix anything that the function above would break.

    I’m guessing you were having an issue with the plugin fixing elements. May I ask what the problem was?




    I am sorry your plugin was perfect, another plugin overwrote it, I think it was the Super Cache plugin…

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WordPress HTTPS] bloginfo http/https on "Disable Automatic HTTPS"’ is closed to new replies.