Support » Plugin: WordPress HTTPS (SSL) » [Plugin: WordPress HTTPS] 404 Error

  • Resolved angeldazie


    Hi! This plugin sounds great. I don’t get the “force ssl” as an option either, but it does got to SSL when I enter the value. The problem is that the “page is not found” on https. What do I need to do to make that happen?? I can’t figure out how it works. If I just load a file outside of wordpress and add https it loads just fine, but nothing in wordpress will load with ‘https’ why is this and what do I need to do?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Mike Ems


    Hey angeldazie,

    What version of WordPress are you using?
    What kind of SSL certificate do you have?

    Generally, you won’t get the checkbox on your posts and pages when your version is below 2.8, which is not supported. If it’s not showing up and you have a more up-to-date version, I would like to take a look at your installation to see what’s causing that problem so that I can patch it if it is really a bug.

    Most of the time, when your permalinks stop working when viewing your site as HTTPS, this is due to the SSL certificate or hosting environment. If you disabled your permalinks, your site would probably work as expected. This, of course, is not an ideal solution.

    Let me know and we’ll go from there. 🙂


    I am getting the same issue. (RE 404 Error – Page not Found) I have read a bunch of forum posts but not too many people having this issue. I tried your suggestion of taking off the permalinks but that didn’t work. My hosting shows both a http folder and a https folder. Do I need to put something into the https folder in order for it to work? It does recognize the content (html and associated graphic) currently in https.

    Really really appreciate any help you can offer with this.

    —– OMG I actually have it running … if I could type little jumping up and down icons I would. I had to change my setting in Plesk to Use a single directory for housing SSL and non-SSL content.

    A BIG thank you to this guy:

    And a huge thank you to you for developing this plugin… running off to donate.

    I’m having the same 404 issue, except I don’t see a https or http folder. I have the SSL certificate in the users directory. I don’t use custom permalinks. As soon as I used the Force SSL option I get a 404. I’m not sure if the server I’m on uses Plesk.



    Fixed! It was my web configuration not including http and https in the same configuration.

    @peaksmedia – Thanks a million for posting your fix. We are hosting on Plesk as well and you just saved me an afternoon of potentially major frustration.

    Same problem.

    Host at Site5. Apache with MOD_SSL

    When I click force or External HTTPS Elements, all I get is 404 errors.

    Using PositiveSSL certificate from NameCheap/ Comodo.

    Any solutions as of yet?


    Got most of problems solved with 404 errors by changing permalinks to default. Now when going a page, get 404 error.

    Posts are fine, but every page produces a 404 error.

    If developer is interested

    Only things I have checked are:

    Internal HTTPS Elements
    External HTTPS Elements
    HTTPS Front Page

    Tried just about every combination with no luck.

    @texasbiz, did you get it working? I was able to see your site, posts AND pages with no problem.

    The site I am trying to fix is also on Site5.


    Hi Jeff.

    Well, had it working. Removed my custom permalinks and used the full URL like this in the “General” area. Both WordPress and Site fields.

    I also chose to download the games and thumbs.

    But, updated to latest version (2.11) and getting all kinds of errors. The games no longer appear when clicking on title.

    When trying to update games (add more in backend) get tons of errors like Warning: Invalid argument supplied for foreach() in /home/four11ce/public_html/fbgames/wp-content/plugins/myarcadeblog/myarcadeblog.php on line 1662

    So, back to not working after update to version 2.11. Also running WP version 3.2.1 if the creator is interested.

    Update: Got the plugin working again and displaying games. Not sure how, all I did was turn custom permalinks on and then back off.

    So games now appearing, but still getting all the nasty errors in the backend plugin area.

    I also had this same issue on a site I was working on. Determined that SSL would resolve pages correctly with permalinks off.


    Add rewrite rules to SSL configuration under the <Directory> tag inside the SSL VirtualHost definition.

    Hope this is helpful 🙂


    <Directory /var/www/sites/>
    AllowOverride none

    Order Allow,Deny
    Allow from all
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: WordPress HTTPS] 404 Error’ is closed to new replies.