Support » Plugin: Google Forms » [Plugin: WordPress Google Form] Error in widget after submitting

  • Resolved jflug

    (@jflug)


    I have a form that works properly on a page or a post, but when I insert it into a widget, you get an error message after submitting “Unable to retrieve Google Form.” The results show up in the form, but I don’t want my users seeing that message. What can I do?

    http://wordpress.org/extend/plugins/wpgform/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi to the author !

    Recently, I tried to update the plugin [ from 0.23 to 0.24 version ] but to no avail. I faced an error upon updating it automatically through WordPress backend. The error which was shown is "Plugin could not be activated because it triggered a fatal error" Warning: require_once(wpgform-core.php) [function.require-once]: failed to open stream: No such file or directory in ../mydomain.com/wp-content/plugins/wpgform/index.php on line 28.
    `
    Can someone help me on this matter? or I’d rather like the author himself explaining.

    Thanks.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I will have to try putting my test form in a widget – I can’t think of any reason off the top of my head as to why that wouldn’t work.

    As to the second issue, it sounds like the upgrade didn’t complete correctly for some reason and a file is missing. I would delete the plugin and re-install it and see if the problem persists.

    Hi Mike!
    I tried your suggestion but the problem persists. I’ve never seen such problem upon upgrading any other plugins before. It triggered a fatal error when deleting and upgrading,vice versa.

    Anyway, your help and quick response is always welcome.

    Thanks for the reply.

    Hi Mike.

    Thanks for your help on solving this matter. I did contact my webhost to solve the issue and it’s resolved. Take a look at this contact page that I build after sucessfully installed your latest version ( 0.24 ) plugin.Great!

    The link : http://madupakhaji.com/testingwp/wpgf

    I discovered that the issue is somewhat revolving around chmod permission.

    Again. thanks a lot . Hope to see more development on this nice plugin!

    Regards…
    Sam

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Glad to hear you resolved the problem, it was an odd one. What additional features do you think the plugin needs?

    Hi Mike..!
    Just a small ten cents idea..default background or logo for the plugin..or maybe it was developed earlier. Sorry, if I had overlooked the overall plugin documentation.

    Regards…

    mindacatur.

    @MikeWalsh

    Thanks for the plugin. I wanted to use your plugin because of the widget functionality.

    It works but for some other reason multi line text boxes did not reduce in px size when I changed the column width.

    input.ss-q-short {
        width: 180px;

    I had to change some more CSS functions.

    My issue at the moment is that I got that sorted but not the multiple line spacing between various text boxes.

    You can have a look at the form in the bottom right widget area. http://capeholidays.info

    Any ideas on how I can remove the multiple blank lines in between entries?

    ————————-
    For others:

    I also had to changed the following code to get multi-line text input area widths reduced: Thanks to Aidan at Google+ who assisted me http://goo.gl/aGG1U

    textarea.ss-q-long {
        background-color: #e0e0e0;
        font-family: "Trebuchet MS", Verdana, Arial, Helvetica, sans-serif;
    }

    Then replace it with this:

    textarea.ss-q-long {
        background-color: #e0e0e0;
        font-family: "Trebuchet MS", Verdana, Arial, Helvetica, sans-serif; width: 180px !important;

    The width depends on your widget width.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Glad you worked out the width issue – I’ve also set the width to be something like “98%” or similarly close to 100% value so it fits the width of the parent element without having to use a specific width.

    With respect to the extra white space on your form, the first thing I’d look at is whether or not you have the br=’on’ attribute in your short code. It looks like you do based on the HTML on your form. I’d try setting it to off using br=’off’.

    There also appears to be something inserting paragraph tags in your widget. If you look at the HTML for your widget you’ll see stuff like this:

    <p>
    <br>
    </p>
    <div class="errorbox-good">
    <div class="ss-item ss-item-required ss-text">
    <div class="ss-form-entry">
    <label class="ss-q-title" for="entry_2">
    <br>
    <label class="ss-q-help" for="entry_2"></label>
    <br>
    <input id="entry_2" class="ss-q-short" type="text" value="" name="entry.2.single">
    </div>
    </div>
    </div>

    In particular, there are paragraph elements which contain nothing other than a line break element. These are contributing most of your white space issues.

    Mike

    Mike. Thanks again answering my question. And so quickly. 😉

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I think we’re all set! Some tricky CSS to sort out but we got it.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: WordPress Google Form] Error in widget after submitting’ is closed to new replies.