Support » Plugins and Hacks » [Plugin: WordPress Firewall] Not Working with WP 3.0 Beta 1

  • Here are lines 217, 218, and 219:

    foreach(
    	unserialize(get_option('default_WP_firewall_whitelisted_page'))
    	as $whitelisted_page){

    Here is the error message generated:

    Plugin could not be activated because it generated 432 characters of unexpected output.

    Warning: unserialize() expects parameter 1 to be string, array given in <url snipped> /wp-content/plugins/wordpress-firewall/wordpress-firewall.php on line 218

    Warning: Invalid argument supplied for foreach() in <url snipped> /wp-content/plugins/wordpress-firewall/wordpress-firewall.php on line 219

    http://wordpress.org/extend/plugins/wordpress-firewall/

Viewing 1 replies (of 1 total)
  • This issue doesn’t seem to be present now (it may have been an issue with WP beta…). I’m releasing a modestly updated version of this plugin…a few fixes, etc, just so you know.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: WordPress Firewall] Not Working with WP 3.0 Beta 1’ is closed to new replies.