Support » Plugins and Hacks » [Plugin: WordPress Firewall 2] Thank you

[Plugin: WordPress Firewall 2] Thank you

  • Your plugin caught 78 attacks on my blog this morning in a 5 minute period.

    It catches a few attacks most days but this was amazing. And that was the number of unique emails I received, there may have been more that were repeats.

    I added the ip address to blacklist on my .htaccess file and agree that it would be great to have that capability in the plugin. Actually, I like to be able to let it block any ip creating a security violation x number of times in x seconds.

    Thanks, again, for this. I appreciate your efforts.



Viewing 15 replies - 1 through 15 (of 17 total)
  • Hey, Brunsona, how do you blacklist an IP address?

    thanks 🙂

    Hi brunsona,

    I’m a new website owner and also very happy with the Firewall. Lately, however, I keep getting attacks from the same IP adress. Like DoZ, I would also like to ban this adress. I read the article, but, where do I put the code?

    You put the code in a file named .htaccess located in the root directory of your web site – the same place where your WordPress files are located.

    To deny access to a single IP address and allow everyone else, paste this code into your .htaccess file and change the to the IP you want to block.

    Order allow,deny
    Deny from
    Allow from all

    You can create a .htaccess file with any text editor. Just open a blank text file and save it with the name .htaccess. Then FTP it to your site. Paste the blocking code in, change the IP address as needed, add more lines with “Deny from” and another IP, etc.

    There are lots of other good uses for a .htaccess file and Google will give you links to tutorials and info.

    Hope this helps,

    Thank you for the quick response! That sounds complicated but I’ll try. I’m getting attacked in waves of 20 every 15 minutes. Do you think I’m at risk? Will they be able to get in? I have no idea what to do…

    Hey you, nice lady!
    Try this:

    Ah thank you! Much easier!
    As we say in the Netherlands: hartstikke bedankt!

    Ok don’t laugh at me but… I have managed to ban myself! WordPress Firewall 2 identified an offending IP adress and when I banned it, I found out it was me. So I guess I’ll have to log in with on another computer and unban my IP adress.
    But how strange that it was me?!



    You could also use a proxy, log in and then unban yourself (I’m not sure if you realize, but if you use a different computer on the same network, like your home network, you’ll likely have the same external IP address). If you do use a proxy or a public computer, be sure to clear any logs and change your passwords!

    As a sidenote, was it your IP address that was “attacking” your website in waves of 20 every 15 minutes, or was that a different address?

    Maybe you are on a shared IP? Or maybe you have your own virus on your own Pc?? … ?_?
    Next time you should check first at the top of Ban options page, where it says your IP, Host name, etc.

    (PS: in Italy we say ‘grazie mille’)

    I managed to unban myself by logging in with a smartphone. But yeah, it was definitely my IP adress. I don’t get it… But it has stopped for now…

    @ DoZ.. According to my McFee protection my laptop is clean… I’m on a secure wireless internet connection at home. Curious aye…

    Happy for you.
    Remember: as I did learn by myself there’s a pugin for everything!

    Florence wrote:

    @ DoZ.. According to my McFee protection my laptop is clean… I’m on a secure wireless internet connection at home. Curious aye…

    If you’re talking about McAfee, then you could still have an infection on your PC. I’ve worked on PCs for a living for a very long time and I just cleaned one up that was hi-jacked by the FakeAlert virus that McAfee did not detect/prevent/nor remove.

    Please consider Malwarebytes, SuperAntiSpyware, and there is other freeware out there that can help protect you. McAfee is not good enough by itself.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: WordPress Firewall 2] Thank you’ is closed to new replies.