WordPress.org

Forums

WordPress Firewall 2
Prevents access to Better WP Security in Multisite (8 posts)

  1. Philip John
    Member
    Posted 3 years ago #

    When using Multisite with both WP Firewall 2 and Better WP Security network-activated, the Firewall plugin blocks access to the network settings page for Better WP Security (http://example.com/wp-admin/network/admin.php?page=better_wp_security)

    Adding the settings page to the whitelist has no impact. De-activating WP Firewall does the trick.

    http://wordpress.org/extend/plugins/wordpress-firewall-2/

  2. slackerofthemind
    Member
    Posted 3 years ago #

    +1 on this issue *without* a multisite. Whitelisting fails to allow Better WP Security to open its Dashboard links.

    Given Better WP Security has nearly the same firewall parameters built in, I have deactivated Firewall 2.

  3. Ed
    Member
    Posted 3 years ago #

    Add your IP to the whitelist. Also Firewall 2 isn't really Multisite enabled, each site has it's own settings so if you have a lot of sites you won't have much fun. I'm looking at hardcoding everything for the time being.

  4. Philip John
    Member
    Posted 3 years ago #

    Thanks for the update. IP might be tricky because I'm going through CloudFlare but I'll come back if it is...

  5. Ed
    Member
    Posted 3 years ago #

    Tried subnet IPs?

    204.93.240.0/24;
    204.93.177.0/24;
    199.27.128.0/21;
    173.245.48.0/20;
    103.22.200.0/22;
    141.101.64.0/18;
    108.162.192.0/18;

    Not sure if there's been anymore added, that's what we use though.

  6. Ed
    Member
    Posted 3 years ago #

    Could try just modifying the options in wordpress-firewall2.php

    add_option('WP_firewall_whitelisted_ip',
            serialize(
                    array(
                            '0' => $_SERVER['REMOTE_ADDR'],
                            '1' => '204.93.240.0/24',
                            '2' => '204.93.177.0/24',
                            '3' => '199.27.128.0/21'
                            '4' => '173.245.48.0/20'
                            '5' => '103.22.200.0/22'
                            '6' => '141.101.64.0/18'
                            '7' => '108.162.192.0/18'
                    )
            )
    );
    update_option('WP_firewall_whitelisted_ip',
            serialize(
                    array(
                            '0' => $_SERVER['REMOTE_ADDR'],
                            '1' => '204.93.240.0/24',
                            '2' => '204.93.177.0/24',
                            '3' => '199.27.128.0/21'
                            '4' => '173.245.48.0/20'
                            '5' => '103.22.200.0/22'
                            '6' => '141.101.64.0/18'
                            '7' => '108.162.192.0/18'
                    )
            )
    );

    I've done similar but with different IPs and it's worked on network activation fine.

  7. Philip John
    Member
    Posted 3 years ago #

    That seemed to sort it, thanks Ed :)

  8. Ed
    Member
    Posted 3 years ago #

    Cool, I'd check if there are any more IP's available at the moment. They're adding more each day afaik.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress Firewall 2
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic