WordPress Firewall 2
"click here to turn off these emails" gives permissions err (4 posts)

  1. Graham Stoney
    Posted 5 years ago #

    Using WordPress Firewall 2, I notice two problems:
    1. The alert emails always arrive as html attachments that Outlook Express can't view directly.
    2. Clicking on the "click here to turn off these emails" gives the error message "You do not have sufficient permissions to access this page.".

    Anyone else noticed this?

    Graham Stoney


  2. pavy
    Plugin Author

    Posted 5 years ago #

    HTML emails are not always reliable (there are many email clients, services, etc., and each has its own way of interpreting). I am about to release an update for the plugin which will contain a plain text email option.

    As far as the permissions issue, I will look into that to see what I can find out.

    Thanks for the feedback!

  3. tdsinfo
    Posted 5 years ago #

    I've just installed Firewall2 and am getting the same permissions error message when attempting to whitelist items using the link in the email.

  4. maduro-blanco
    Posted 5 years ago #


    This seems to be due to a bug which produces an email link missing parts of the address. It misses out wordpress-firewall-2/ from the url e.g. it produces -


    instead of -


    something to do with basename(__FILE__) in its code not firing up properly.

    In the meantime just add the missing bit to the url to get it to work. It should then automatically add the exception to the whitelist if you look down the page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress Firewall 2
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic