WordPress File Monitor Plus
[resolved] W3 Total Cache files created (8 posts)

  1. pmfox
    Posted 4 years ago #

    I'm having issues getting it to stop showing all the pages created by W3 Total Cache plugin. When a page is viewed, the cache plugin creates files like this:


    I have these set up in "Dir Names to Ignore" and "Exact Dirs to ignore" and I've tried with these in only those options.


    The problem is W3 creates a directory for each post, and eventually deletes it. How can I stop getting messages of these cache files without listing each postname directory?

    Is there a setting to not receive warnings on any subdirectories created?
    Thank you.


  2. Scott Cariss
    Plugin Author

    Posted 4 years ago #

    If you place any full directory path in Exact dirs to ignore than any folder or file underneath that directory gets ignore. That folder is then ignored and not scanned.

    Please double check the directory you are entering is correct.

  3. pmfox
    Posted 4 years ago #

    I'm copying the directory straight from the file monitor plus update.

    I updated Exact Dirs to read:
    (actual rootname in directory below home)

    I made the change and cleared the cache & file monitor files, etc. I went to the site and it's still sending monitor updates of any files created in the w3tc directory.

    Is it because W3 creates a subdirectory in the w3tc directory for each page that's generated? Or will this also ignore directories created too?

    Thanks for the quick reply!

  4. pmfox
    Posted 4 years ago #

    I removed the trailing "/" and it seems to have cleared the issue.
    Can't believe I didn't try that before.

  5. Scott Cariss
    Plugin Author

    Posted 4 years ago #

    Hello pmfox,

    Glad you resolved the issue. I'll be sure to put a measure in the next version to make sure the trailing slash is auto removed so that other users don't fall for the same problem.

  6. Scott Cariss
    Plugin Author

    Posted 4 years ago #

    I have now put a measure in place in version 1.3 that stops you leaving a trailing slash on the end of the directory. Please make this post as solved.

  7. fancypantsdesign
    Posted 3 years ago #


    I'm having the same issue as the user above. I really would like to use this plugin to monitor WP site files in case of a malware attack.

    If i enter the exact directories without the trailing slash as above it will work for those directories only. W3TC however, creates new subdirectories and these are picked up in manual scan.

    Is there anyway to use a wildcard * type arrangement?

    e.g how do i make sure that /home/website/public_html/wp-content/w3tc and all of the subdirectories that are automatically created are excluded from the scan?

    Thank you for the great plugin.

  8. Scott Cariss
    Plugin Author

    Posted 3 years ago #

    If you place: /home/website/public_html/wp-content/w3tc in Exact Dirs To Ignore setting then it will ignore that directory and everything in it.

    If thats not working then please double check that the location is correct and that its on its own line.

    Kind Regards


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress File Monitor Plus
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic