Support » Plugins » [Plugin: WordPress Exploit Scanner] Cannot allocate enough memory to run file scan

  • Heyo, I just tried to run the file scan but I get the following error

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 60613024 bytes) in /home/user/dbzer0.com/wp-content/plugins/exploit-scanner/exploit-scanner.php on line 84

    I guess this is becasue I’m on a Virtual Private Server and have a maximum amount of RAM I can use at any point. However it’s more than 134Mb and even if increase it to 1Gb, I still get the same error

Viewing 14 replies - 1 through 14 (of 14 total)
  • It’s not your servers memory that is the issue, it’s the amount of memory PHP is allowed to use. This is set in the php.ini file on your server. You should be able to edit your PHP configuration either by directly editing the php.ini file, or through your hosting control panel, especially if you are on a cPanel host. The PHP setting you are looking for is memory_limit

    Isn’t there a way to make the plugin require less ram at any one point?

    It really depends on how the plugin was written. 134Mb of RAM is a lot of memory for a plugin, or any PHP script to use, but this plugin is doing quite a bit so it will use a lot. I have never seen this plugin use that much memory, so perhaps the version you have has a memory leak at some point. Are you running the latest version?

    Yeap. Th funny thing is that it does not simply try to use 134Mb but rather it’s trying to allocate 606Mb and fails once it can’t get past 134

    Yeah, guess I missed that – 606Mb is a whole lot of memory for a PHP script – sounds like a memory leak, but it could be caused by some other plugin on your site. Can you disable all plugins except the exploit scanner then try to run it and see what happens?

    Egh, I’d rather avoid doing that if possible. I’ve got a lot of them and some are a pain to re-enable. I’ll keep this as a last solution if I really need to use this plugin.

    I have the same issue.

    I think the guilty plugin for me was the Excerpt Editor. Do you have it perhaps?

    Laura J

    (@rainfrog)

    I have the same problem with this plugin. No matter how much memory I give it via php.ini I cannot get it to run. It always fails. 900mb should surely be enough I would think!

    I’ve also disabled all plugins except for it and then run it and it STILL times out because of not enough memory.

    I gave up. If there’s a solution to this, I’d love to know. For now, I can’t use it.

    [Tue Oct 20 20:32:47 2009] [error] [client xxxxxx] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 766154752 bytes) in /xxxxxx/wp-content/plugins/exploit-scanner/exploit-scanner.php on line 80, referer: http://xxxxxx/wp-admin/index.php?page=exploit-admin-page

    uses a lot of memory on my side

    I have the same issue too on first-run. I really don’t feel like I should have to change anything on my end to make the plugin work if it’s well-developed.

    Fatal error: Out of memory (allocated 21495808) (tried to allocate 56213504 bytes) in /plugins/exploit-scanner/exploit-scanner.php on line 80

    I’ll deactivate and try again after updates. Sounds like a marvelous idea if it worked.

    Ladybug – it is well developed but recursively digging through directories take a lot of memory unfortunately. The readme.txt has a suggested solution – allocate more memory. That will fix the problem if your host allows you to allocate that much memory.

    If you have lots of directories that aren’t used (much or anymore) then removing them will reduce the amount of memory used.

    when you say remove directories, are you speaking about plugins, or themes, or anything we can find.

    Ladybug, what plugin did you activate to cause this problem ? … i ask cos i have the same proble, maybe we both use the same plug in ?

    Jeff

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: WordPress Exploit Scanner] Cannot allocate enough memory to run file scan’ is closed to new replies.