WordPress.org

Support

Support » Plugins and Hacks » WordPress Dashboard Twitter » [Resolved] [Plugin: WordPress Dashboard Twitter] White Page when click sign in with twitter

[Resolved] [Plugin: WordPress Dashboard Twitter] White Page when click sign in with twitter

  • The subject above say most of it. The problem im having ive installed the plugin and i click on “Sign in with Twitter” badge and it try to redirect me to some page but all i get it a white page and nothing else.

    Ive used Twitters new OAuth on other plugins and ive set up and applcations in twitter for “Consumer key” and “Consumer secret” so if there a way to manual configer it your self it would be great if someone knows how to get rid of white page im getting. Im not even sure where its trying to send me, I can post like to where badge sends me if you need.

    Thanks for any help and sorry for long message tried to explain as best as i could.

    http://wordpress.org/extend/plugins/wordpress-dashboard-twitter/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author wpseek

    @alphawolf

    Hey bballuk,

    what PHP version are you running on?

    All my info below incase more needed.

    Server Information
    VistaPanel version: 2.4.1 RC3
    Operating system: Linux
    Apache version: 2.2.15 (Unix)
    PHP version: 5.2.13
    MySQL version: 5.1.45

    Plugin Author wpseek

    @alphawolf

    Try adding

    define('WP_DEBUG', true);

    to your wp-config.php file.

    If this makes an error message be displaying, please post it here.

    When i click on Login into Twitter still wait page no errors but when im on WP Dashboard there loads at the top here they all are.

    Notice: Undefined index: action in /home/vol7/byethost33.com/b33_8067579/htdocs/wp-content/plugins/wordpress-dashboard-twitter/inc/upload.func.php on line 2
    
    Notice: Undefined index: tw_flush_cache in /home/vol7/byethost33.com/b33_8067579/htdocs/wp-content/plugins/wp-tweet-button/wp-tweet-button.php on line 443
    
    Notice: Undefined index: tw_flush_cached_shortlinks in /home/vol7/byethost33.com/b33_8067579/htdocs/wp-content/plugins/wp-tweet-button/wp-tweet-button.php on line 427
    
    Notice: Use of undefined constant THEME_NS - assumed 'THEME_NS' in /home/vol7/byethost33.com/b33_8067579/htdocs/wp-content/themes/AG_Theme/functions.php on line 7
    
    Notice: Undefined index: id in /home/vol7/byethost33.com/b33_8067579/htdocs/wp-content/themes/AG_Theme/functions.php on line 203
    
    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/vol7/byethost33.com/b33_8067579/htdocs/wp-includes/functions.php on line 3387
    
    Notice: Undefined index: do in /home/vol7/byethost33.com/b33_8067579/htdocs/wp-content/plugins/wordpress-dashboard-twitter/wpdt.class.php on line 160
    Plugin Author wpseek

    @alphawolf

    Well, these are “just” notices so nothing to worry about, and these aren’t repsonsible for your white page error.

    Well, white/blank pages can have numerous reasons. Are you using a po/mo localization file?

    I dont know what po/mo localization files are mate can you explain.

    Plugin Author wpseek

    @alphawolf

    That is, if you’re using a localization file/another language than english on your blog.

    No then im not useing any ive got a test site setup up with plugin installed and its does the same as mine i can give you access to it as admin if you want to see if you can sort it then.

    Do you think it could be my host blocking something im using free hosting from byethost.com also wordpress.com host does it allow you to install plugins or no ?

    Plugin Author wpseek

    @alphawolf

    Well, that’s possible too. Would you send me your admin account data to your WP Dashboard to scripts (at) schloebe (dot) de (not the spam protection)? I’ll see what I can do.

    Plugin Author wpseek

    @alphawolf

    Hey bballuk,

    got your email and login and nailed it down to curl. You don’t seem to have curl enabled in your PHP installation which should be turned on by default in 5.2.x

    Try asking your webhost to enable it for you. 😉

    i dont think they will they disable a few things because people where taking advantage of the free service.

    Plugin Author wpseek

    @alphawolf

    Well, they can still enable it for your webspace only, though. That is if they know what they’re doing.

    You’ll need curl to use the plugin, there’s no way around unfortunately.

    Ive looked on there forums about other people request to be unrestricted on a some settings and they wont they tell you get a paid account i think i might have to look for a new free host. I finally find one that works and do all ways timeout and then this lol.

    thanks for all help. Is there any other way of using plugin without using cURL ?

    Plugin Author wpseek

    @alphawolf

    Well, a whole lot of WP plugins with remote requests use curl, so after all it would be good to switch the hoster to avoid any future problems with other plugins.

    My plugin inherits a Twitter class that requires curl, so you need to go with curl in order to be able to use the plugin.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] [Plugin: WordPress Dashboard Twitter] White Page when click sign in with twitter’ is closed to new replies.
Skip to toolbar