Support » Plugins and Hacks » WordPress Backup to Dropbox » [Resolved] [Plugin: WordPress Backup to Dropbox] Version 1.2.2 No Longer Backing up Database

[Resolved] [Plugin: WordPress Backup to Dropbox] Version 1.2.2 No Longer Backing up Database

Viewing 15 replies - 1 through 15 (of 17 total)
  • So do I. I don’t see any database file in my dropbox account. Is it bug or the feature has been removed?

    Just found this on another support thread

    I found this in the FAQ:
    “Where is my database SQL dump located?
    The database is backed up into a file named ‘[database name]-backup.sql’. It will be will be found at the path ‘wp-content/backups’ within the App folder of your Dropbox.”

    I found mine

    Yes, but see my original post. Mine hasn’t been updated since July 31st. It’s not updating the SQL backup.

    Plugin Author Michael De Wildt


    How big is your database?

    Are you getting any errors in the Plugin, WordPress or Server logs?

    Well, the last sql backup I have (dated July 31) is only 3.1 MB so the database can’t be that big.

    No errors in the server logs I have access to. When I go to the plugin page it just says the backup ran. Any idea where else I could look for errors?

    Plugin Author Michael De Wildt


    3.1 megabytes for a small blog sounds about right. My blog is only 3.9 megabytes and my other site around 500k.

    same here no longer working

    Backup error on 2012-09-07 at 08:58:18: Exception – Error creating sql dump file.
    Backup started on 2012-09-07 at 08:58:09
    Backup error on 2012-09-07 at 08:38:26: Exception – Error creating sql dump file.
    Backup started on 2012-09-07 at 08:38:17

    the big problem is you have no idea it has failed as no error message shows unless you click on the settings to see the history.

    On my setting page is says it completed successfully. It shows no errors, it just doesn’t create a new sql dump file.

    Same issue but with added complications. No SQL (or any) backup since Aug 28, as per the ‘wp-content/backups’ list in Dropbox/Apps:

    1. The settings link has disappeared on the plugin page. It just shows ‘deactivate’ and ‘edit’.

    2. After deactivating/reactivating and then deleting and reinstalling this plugin, there is still no apparent way to access ‘settings’ or solve the problem as to resuming daily backups.

    Now running WP 3.4.2 but the problem started before upgrade. Also I recently installed some additional plugins as an extra layer to stop persistent bots and spammers, including an IP Filter and Bad Behaviour. They’re doing the job but just wondering if these are contributing to the problem in some way.

    Help please….

    Okay, ignore my first post – solved (hopefully)! Always right after one presses ‘post’…sigh..

    I forgot that access to backup settings is via the WPB2D tab on the main menu bar on the left of the dashboard. However, what became apparent is that one has to re-authorise the Dropbox link AFTER upgrading to 1.2.2….

    Duly authorised…move along citizens…back to work, nothing doing here.

    Yeah. I know. PIBKAC.

    [Problem Is Between Keyboard And Chair]

    …and also then reschedule backups. I suspect that I needed to do this after reinstalling the plugin, so this may only apply if you resorted to that measure.

    Plugin Author Michael De Wildt


    Gday all….

    The error “Exception – Error creating sql dump file.” is usually due to file permissions, yo u need to make sure that the wp-content/backups directory is writable by the server.

    Thanks for your feedback regarding logging, Better logging is now the most requested feature that I plan to better in the next release.


    my folder is set to 755 there is no way on this planet i will set it to 777, the thing is it worked before so why would it suddenly stop working?

    the other thing is the little bit of wording telling us to get a coffee should also report the error there as i left it for 2 hours + not knowing it was even working frustrated ! lol


    Ok, the more I look at this, the issue isn’t that it’s not creating a sql file, it’s not doing the backup at all. However, when a backup runs the admin page shows this:

    Backup completed on 2012-09-09 at 09:38:14
    Backup started on 2012-09-09 at 09:38:13

    There is nothing in my error logs, but nothing is backing up. Any ideas where to start? I’ve used this plugin a long time and not had an issue for a long time.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] [Plugin: WordPress Backup to Dropbox] Version 1.2.2 No Longer Backing up Database’ is closed to new replies.
Skip to toolbar