Support » Plugins » [Plugin: WordPress Automatic upgrade] Will not activate plugins on the last step

  • This problem started cropping up since WordPress was moved to version 2.5. The plugin worked just fine in previous versions.

    What happens is that the whole upgrade process moves normally. I upgrade the database and all, and then I try to reactivate my plugins. At this point I will always be taken to the login screen as if my cookie had suddently expired. After I login, I am taken to the WPAU page where I am asked if “I am certain I want to do this” (or somesuch, can’t remember the exact message). I click the “try again” option but it will just return me to that screen.

    In the end, all the plugins are left disabled, except WPAU. and I have to manually activate all of them. This wouldn’t be a big issue if I didn’s have close to 30 plugins :-/

    Since I run multiple WP sites, I tried another thing. When the “activate plugins” step arrived, I open a new tab to my admin page and logged in from there (just to get the cookie). Unfortunately this did not help as when clicking to reactivate the plugins I was taken to the same “Are you sure” screen again.

    I assumed this might be related to the change from 2.3 to 2.5 but when trying to move from 2.5 to 2.5.1, the same problem appeared.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I run about 30 WP installations an this is a big issue for me also!

    i also have this kind of issue…with the same kind of message as Db0. i wrote to the author but i didnt get any reply from him. the only thing that matters to me is to know if the upgrade went fine in the end. i hope the author will sove it!

    I had the same problem and more than that I now cannot see my posts – I only see the Title of the post?



    I have to pipe in too and say this happens to me always. I just upgraded to 2.6 and everything went smoothly except for this, exactly what db0 said.



    At least now with 2.6, this is not so annoying since you can activate plugins in bulk.

    Still would be nice if it was fixed though

    But….the plugins can only be activated in bulk IF they all work correctly with the version of WP you are upgrading to! If not, you get “Plugin could not be activated because it triggered a fatal error.” but it does NOT tell you what plugin caused the error. So you have to activate everything manually. And I have 80+ plugins……

    Use the splitting method

    Activate 40. If they fail, activate the other forty
    Then activate 20. If they fail activate the other 20
    Then activate 10 etc…

    Thanks for making that suggestion. Actually, that’s more or less what I did, and in so doing, narrowed it down to the two that were actually causing the problem. I appreciate hearing how others tackle a situation, esp when it reinforces that I’m on the right track. 🙂

    It would be really nice if the auto upgrade gave a really useful error message, like “The following plugins caused a fatal error. Please remove them from the list, the reactivate the remaining plugins….” followed by a list of bum programs. But for now, the “splitting method” as you called it, will have to do! 🙂

    Thanks again!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: WordPress Automatic upgrade] Will not activate plugins on the last step’ is closed to new replies.