WordPress.org

Support

Support » Plugins and Hacks » WordPress-Amazon-Associate » [Resolved] [Plugin: WordPress-Amazon-Associate] Amazon ad not showing on user end of blog.

[Resolved] [Plugin: WordPress-Amazon-Associate] Amazon ad not showing on user end of blog.

  • I have installed WordPress Amazon Associate. I’m an Amazon affiliate. I also signed up with Amazon Web Services and got my access key and secret key validated. Then, I went to Amazon Affiliates and copied the HTML of a book I want to advertise. (I’m using WordPress.org, so no problem there.) I pasted the code in the HTML view of the page I’m using, and updated the page. I got a yellow box in the visual view of the page, and nothing shows up on the user end of my website. I also tried used the code from the Amazon Quick Links, where you edit the page, but same result. Can anyone help me figure out why it’s not showing up? I did have success once, with one book, a few days ago, but I don’t know what I did differently and I’ve deleted that one now. Thanks in advance!

    http://wordpress.org/extend/plugins/wordpress-amazon-associate/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Matthew Denton

    @mdbitz

    Hi, there are multiple ways to insert product links into your page/post from the WPAA plugin. When you use the Quick Links you should notice that some shortcode is added to your page content similar to [amazon_link ...]...[/amazon_link]. When you preview the page you should see the content displayed on the page.

    Since Quick Links is functioning for you that means that the plugin has validated your AWS credentials and is able to search for products from the Amazon Product API. If you send the post/page content to matt@mdbitz.com I can load it in a test environment and see if there is any issues within my environment.

    Thanks so much for the help! I actually found out that the reason the ads were not showing was I had adblock activated on my browser. Once I deactivated it, they showed up fine. However, I decided to use text links instead of the beautiful, framed ads, because I figure if I didn’t know I had Adblock activated, my readers probably don’t either. They won’t see my ads if Adblock is activated on their browser. This is a pretty significant issue if you’re trying to sell stuff, lol! I will try the plugin again – I had deactivated it to try to isolate the problem. Thanks again!

    Plugin Author Matthew Denton

    @mdbitz

    Adblock restricts the Amazon Enhanced ad as the content is served directly from Amazon and gets recognized as an Ad. If you define product ads using the template feature of the plugin then they don’t get blocked by Adblock.

    Awesome! I will try that! Thank you!

    What happens if I do not enter an Amazon Associate tag under the first box where all the locations are listed? Should I enter my tag for all locations? If I leave it blank, will that prevent me from getting a percentage of any sales? Thanks!

    I reactivated the plugin and used the template feature to insert an ad. (Is the template feature the Amazon Quick Links feature I see when I go to edit my pages? It doesn’t say template, so I am not sure that’s it.) Anyway, that’s what I used. So, I am able to display an image of the book, but when I insert the “Enhanced Link” (which is the nice ad I also find on Amazon), it doesn’t show unless Adblock is disabled. So somehow Adblock is still detecting the ad. Am I doing this properly? I would really like to be able to show the framed ad. Thanks for your help!
    Lisa

    OK, I am learning. I read about the plugin templates, and I understand I must insert %TAG% somewhere into the template. I’m not sure where I would insert that on the page. Would I first insert the Amazon HTML code for an ad, and then add the appropriate tab? Where would I put it in the code? I am totally new at this, obviously. Thanks for the help!

    Plugin Author Matthew Denton

    @mdbitz

    Hi:

    Currently I haven’t integrated support for the new Template Feature into the Quick Links or TinyMCE controls and you need to insert the code manually into the post. Let me try to answer your above questions.

    1) You need to put in your associate tag into the WPAA > Settings page to get credit for any sales. If you only use a single locale then you need to only insert your associate tag for that locale if you want to use Geo-Localization then you will need to insert your associate tag for each locale.

    2) “Enhanced Links” are ads served directly by Amazon and get blocked by AdBlock. Templates are rendered as part of your page and as such don’t get blocked. To use you need to insert code similar to below in your post/page content

    [amazon_template template="5" id="0451463471" ]Changes by Jim Butcher[/amazon_template]

    You would change the id to the ASIN of the product you want to show and template to the id or name of the template you want to use. 5 is a Product Summary and contains the most information at this time.

    The links and buy now button that are part of the outputted content will already contain your associate tag if configured in the settings page.

    Thanks so much! This is very helpful.

    Wonderful! It worked! And I know nothing about code. Great job with this plugin and the support to help us newbs!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] [Plugin: WordPress-Amazon-Associate] Amazon ad not showing on user end of blog.’ is closed to new replies.
Skip to toolbar