Support » Plugins and Hacks » [Resolved] [Plugin: Wordfence Security] Slow

[Resolved] [Plugin: Wordfence Security] Slow

  • skonsult


    I like this plugin alot but it slows down my site. I ran a couple of Pingdom tests and after deactivating Wordfence by grade went up two notches, from 95 to 97.

    There is a thread at wordfence.com where a user is experiencing the same thing. Anyone else that noticed that a site is slower after activating Wordfence?

    Any authors that can comment on this?


Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Wordfence


    Hi Skonsult,

    I’m the author of Wordfence.

    In genera, things that slow down a site most are not parts of your web application (WordPress and it’s themes and plugins in this case) that consume CPU. But rather things that do IO (Input Output) to disk.

    When you enable Wordfence, the most IO intensive thing that it does is to log your traffic for the Live Traffic view and to query the geographic database that we bundle with Wordfence to figure out where your visitors are in the world.

    If you disable the Live Traffic feature you will probably see an improvement in speed because we will no longer log that data.

    If you are a premium member and are using the Country Blocking feature, you can also stop using that and you may see a slight increase in speed, although this routine is incredibly fast so I doubt you’ll see much of an increase there. When I say incredibly fast, we’ve benchmarked it at around 20,000 queries per second on a very entry-level server.

    So mainly I’d suggest disabling Live Traffic for a few days and see what your pingdom stats do.

    We are constantly working on improving the speed of Wordfence and it is built for very fast performance. That is why, for example, it creates it’s own DB tables rather than storing chunks in the existing WordPress tables – because having our own tables is very fast. It’s also why Wordfence establishes it’s own separate connection to your database – again for speed.

    So we’ll keep working to make it faster and do let me know what your experience is as you modify your settings.



    I got the same issue with Wordfence.

    Thank you very much for great explanation mmaunder.

    Looking forward for faster Wordfence !!

    Just wanted to note that this worked great for me.

    My site was performing VERY slowly. I turned off the Live Traffic in Wordfence, and now my site is SIGNIFICANTLY faster. Really appreciate the tip.

    Yes me too. I have disabled real time traffic option, but no success. I’m no shared hosting.

    Thanks here too.

    Was about to disable Wordfence – didn’t want to, but it was significantly slowing the site according to P3 plugin. Disabling live traffic has made a huge difference – Has gone from 10+ second load time to 4.

    Same happened to me, thanks

    Sped my site up.

    Hi Mark, thanks for this amazing plugin.

    I just find a problem with it. Database of my website was 30mb, 3 weeks after the plugin was installed is more than 100mb.

    If possible you should add a option to clean up the database.

    Apart from that, excellent security plugin 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] [Plugin: Wordfence Security] Slow’ is closed to new replies.