[Plugin: Wordbooker] Wordbook only sees 2 FB pages even though auth multiple (20 posts)

  1. tonyzeoli
    Posted 6 years ago #

    I'm having serious issues with this plugin.

    I tried to connect to multiple fan pages. It only shows 2 of many when try to ALLOW. Went to Facebook, added Wordbook to other Pages. Still won't see additional pages.

    Deleted plugin. On reinstall, I get error message, can't find page. Now the plugin doesn't work at all.

  2. Steve
    Posted 6 years ago #

    And are you the administrator for those pages?

    Which version have you got installed?

  3. tonyzeoli
    Posted 6 years ago #

    First, sorry for the mis-title. I'm talking about your Wordbooker, not Wordbook by Stephen Tsai.

    Yes, I am the admin for all pages.

    At first, I got just two pages that were legacy attached to the plugin. I was wondering why the plug-in disassociated from the remaining pages.

    I then went to your App page, and figured out that I should add the app to my other pages, if it hadn't been added already. I saw that all the ones I needed were not longer connected, so I added those pages to your app. The primary is Digital Strategy Works. That's the most important.

    I checked my pages Settings in the Edit panel, and I see that Wordbooker is enabled.

    I'm logged into Facebook under my primary account, which manages all of my pages including Digital Strategy Works.

    The plugin had originally worked for my primary, and two pages, but now DSW. Now, the plugin doesn't work at all. When I click to set it up, it sends me to my own site with a Page Not Found error.

    I've deleted the plugin. Logged in and out of Facebook. Logged in and out my blog. Nothing.

    Here is the string: http://digitalstrategyworks.com/wp-admin/options-general.php?page=wordbooker&session={%22session_key%22:%2204695b5f75078e19d2f53f4f-833731%22,%22uid%22:%22833731%22,%22expires%22:0,%22secret%22:%22809846d977c49454b9035c6b51853d35%22,%22access_token%22:%22254577506873|04695b5f75078e19d2f53f4f-833731|u3Hp8n-ITj2D2jV73atUY8IaO28.%22,%22sig%22:%2250d5a7f4a61d7d002e72008bd9a45240%22}

  4. Steve
    Posted 6 years ago #

    A page not found error - thats very odd

    So you go to your blog and into the back end and you go to:

    http://digitalstrategyworks.com/wp-admin/options general.php?page=wordbooker

    That brings up the "Connect with Facebook" option which you click on and it should bring up a Facebook login box followed by a Facebook permissions box (assuming permissions need to be granted).

    It should then return you to the wordbooker options page with the Facebook session information tagged onto the end of it. Which would seem to be what you've pasted.

    So where is the 404 cropping up?

    And what version have you got installed?

  5. Steve
    Posted 6 years ago #

    I just looked at your site.

    Your blog is in http://digitalstrategyworks.com/blog/ but in the HTML its making a lot of WP resource calls to http://digitalstrategyworks.com/wordpress/

    which suggests you've changed the install directory as described here:


    The problem is that my code uses urlencode(get_bloginfo('url')) to build up the call back and that would seem to be returning http://digitalstrategyworks.com

    But your Admin url would seem to be:


    So you could try finding the following line in wordbooker.php:

    $par['next'] = "http://ccgi.pemmaquid.plus.com/cgi-bin/index.php?br=".urlencode(get_bloginfo('url')."");

    and changing it to:

    $par['next'] = "http://ccgi.pemmaquid.plus.com/cgi-bin/index.php?br=".urlencode(get_bloginfo('wpurl')."");

  6. tonyzeoli
    Posted 6 years ago #

    Using 1.8.4


    Click on Wordbooker setup and return 404.


    Not sure if it's a cookie or something that it was looking for before. I'll see if there's a cookie somewhere looking for the old version and not the new version. I'm just guessing that this could be the reason, but I really have no idea.

  7. Steve
    Posted 6 years ago #

    See the post I made above with what I think will fix it.

    Then once we've got it authorising we can chase down the page problem.

  8. tonyzeoli
    Posted 6 years ago #

    Will continue this on Facebook discussion group.

  9. esmi
    Forum Moderator
    Posted 6 years ago #

    Previous post deleted. Please use the pastebin.

  10. tonyzeoli
    Posted 6 years ago #

    Oh, I didn't even know what the paste bin was. Okay. Will do. Steve, I gotta hit you with that by email.

  11. Steve
    Posted 6 years ago #

    Or just use the pastebin here - knowing how flaky FB's messaging/discussion system is

  12. esmi
    Forum Moderator
    Posted 6 years ago #

    Sorry about that, guys but the code was causing problems - to the extent that I couldn't even edit the post in question.

  13. tonyzeoli
    Posted 6 years ago #

    No worries, I understand. Will use pastebin! Thanks.

  14. tonyzeoli
    Posted 6 years ago #

  15. Steve
    Posted 6 years ago #

    Can you try 1.8.5 which changes a couple of URLs which might help.

    Word booker does two calls concerning pages:

    First it gets the list of pages and then does a loop checking for missing permissions.

    Then it gets the name and pageID for all the pages you administer and loads them into the table.

    So what we need to do is work out if its finding all those pages and if it is finding them all why its going wrong.

  16. tonyzeoli
    Posted 6 years ago #

    I'm with the newest version, but it's still not seeing my pages. I am going to delete Wordbooker from my Digital Strategy Works Facebook page and then readd it. Let's see if that works.

    I added Wordbooker to my Netmix blog and when I go through the second loop it's not seeing my DSW page either.

    Let me test that and see what comes of it.

  17. tonyzeoli
    Posted 6 years ago #

    Okay...so I went ahead and deleted the app from the pages on Facebook. Once I did that, I went back into Wordbooker to reconnect my "Netmix" page. The first loop had already completed for my personal profile. I clicked to begin the second loop. It showed me all my pages. I went to select a page, and it seemed not to select the correct page. When I went back to try it again, my pages were gone in the drop down. Something is going on where once you add the app and try to complete the action, it's losing access to your pages.

  18. Steve
    Posted 6 years ago #

    The second loop is a permissions grant. Once you've granted permission then if you've no new pages (or pages you've not granted permission to) then you wont see that second FB dialogue on reset.

    What we need to determine is which pages it is seeing inside Wordbooker.

    So what I need to know is once you've installed it and run through a status refresh what does the pages column for the row in the wordbook_userdata table for your user contain?

  19. tonyzeoli
    Posted 6 years ago #

    Looks like it captured all the pages. See table contents below.

    a:6:{i:0;a:2:{s:4:"name";s:22:"Digital Strategy Works";s:7:"page_id";s:12:"162916183220";}i:1;a:2:{s:4:"name";s:12:"Netmix Media";s:7:"page_id";s:12:"101081820926";}i:2;a:2:{s:4:"name";s:11:"20dot20.com";s:7:"page_id";s:11:"75369552977";}i:3;a:2:{s:4:"name";s:9:"DJ Tony Z";s:7:"page_id";s:11:"50477327609";}i:4;a:2:{s:4:"name";s:6:"Netmix";s:7:"page_id";s:11:"32453991461";}i:5;a:2:{s:4:"name";s:6:"Tony Z";s:7:"page_id";s:11:"21664977513";}}

    If it's connected and has these table entries, shouldn't Wordbooker then hide the FACEBOOK button and tell me that I'm connected? I thought that was how it used to work? You would click once and show you all your general user profile info, then you would click the second button and go through the second process and it would confirm everything in Wordbooker, telling you that it was set up for both your PERSONAL and PAGE. Am I mistaken?

    I'm still seeing this:

    Tony Zeoli ( 833731 )

    (Thu Jan 1, 12:00 am).

    Wordbooker appears to be configured and working just fine.

    Wordbooker requires authorization to publish content to your Wall/Fan pages on Facebook. Click on the following link to grant permission
    Facebook Login Button
    and then save your settings

  20. Steve
    Posted 6 years ago #

    so you click on that Auth button and it should bring up a dialogue prompting to for additional access to the pages.

Topic Closed

This topic has been closed to new replies.

About this Topic