Support » Plugins and Hacks » [Resolved] [Plugin: Wordbooker] Thumbnail not showing

[Resolved] [Plugin: Wordbooker] Thumbnail not showing

Viewing 15 replies - 1 through 15 (of 39 total)
  • Plugin Author Steve


    If its working fine on other sites then it could be almost anything. The problem is with image handling issues is that its impossible to reproduce it which suggests its down to something on that site (or how FB sees that site).

    You are correct it may not be wordbooker as im having trouble getting thumbnails to show thru other services. Like buttons and share buttons do work on facebook though.

    I’ll keep testing things. Let me know if you have any suggestions.

    I did notice that in the diagnostic messages it keeps repeating “Looking for favicon.ico in http:….60×60.jpg “

    Where favicon.ico changes to other things like gravatar, facebook, plugins etc. but its always looking in the correct thumbnail file.

    Plugin Author Steve


    What Wordbooker does is it gets a list of images in your post and then it removes “bad” ones – like icons and graphics from plugins which may well be included in a post. It also removes any FB hosted images and FB will ignore them. So basically that’s Wordbooker tidying up its images before pushing them to FB.

    Are there any thumbnails settings in wordpress that MUST be turned on in order for wordbooker to work properly?

    Plugin Author Steve


    by default if you don’t sent any of the options like “only use featured” image then Wordbooker will find the first 5 usable images in the post – even though Facebook will only use the first one.

    Its not sending anything, the space where the thumbnail is on the facebook is blank.

    Plugin Author Steve


    So do the diagnostics (if you set it to Show All) show it finding any valid images in the post?

    I’m sorry, not sure how to do what you are asking. Where is show all?

    Ok, found it. It is posting the “wordbooker_blank.jpg” to facebook page.

    Ok, it looks like unchecking “Use Post Thumbnail only ”

    and checking “Use Image from Custom Meta instead of Featured Image for Open Graph image”

    has solved the issue.

    thank you steve.

    I’ve run into this same issue today and the above suggestion did not resolve the issue for me. No matter what I check or uncheck, it does not send my featured image or any image form the post to Facebook.

    I get the default image I set on every post. Did I miss something?

    I just tried the following… reset the user session, reconnected, saved settings for wordbooker. I then refreshed the page and clicked the “send” button. This time no image appeared, not even my default (which is set).

    I went to a different post and hit send and got the default image. Went to a third post and hit send and this time got the featured image. Clicked through a few more and had either the featured or the default show up.

    Is there some sort of caching going on that needs to be cleared?

    Plugin Author Steve


    Facebook caches urls and the data associated with them.

    Wordbooker will use the blank image if it can’t find an image in the post. Its pretty hard for me to diagnose what the problem is without any diagnostic trace for a post, and your support information. BUT you can’t post that data here as WordPress will delete it, so you either need to put it somewhere like pastebin or come over to the Wordbooker support forums at :


    I’m not trying to publish anything, I’m just clicking send from the front page so I dont get any diagnostics. Here is a real life example. These two pages use the same page template and each of them has a featured image attached.

    This one shows the proper image when sent:

    This one shows the default:
    (it should show a football player)

    So is this still Facebook caching issue or do you need me try a different test?

    Plugin Author Steve


    You have two sets of og tags:

    One has this as the image:


    one has


    So what plugin have you got apart from Wordbooker that is producing og tags… and which one of those images is correct?

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘[Resolved] [Plugin: Wordbooker] Thumbnail not showing’ is closed to new replies.