Support » Plugins and Hacks » [Plugin : Wordbooker] Bug reports

  • If people are having problems with my Wordbooker plugin rather than just voting saying its “broken” can you please post some information and I’ll look into it.

    I know that it doesn’t play well with some other Facebook plugins down to the fact that they are using old and obsolete versions of the Facebook API client libraries which don’t support the methods this plugin uses. Unfortunately there isn’t a lot I can do about that.

Viewing 15 replies - 1 through 15 (of 85 total)
  • Plugin doesn’t even activate. I get this error:

    Plugin could not be activated because it triggered a fatal error.
    
    Parse error: parse error, unexpected '{' in /export/vol7/httpd/htdocs/band/wp-content/plugins/wordbooker/wordbooker.php on line 140

    I’m stuck on a really crummy server running PHP4, so maybe that’s it.

    Unfortunately it needs a minimum of php5 – Facebook don’t support php4 any more.

    I use MarsEdit to work on my blog. I noticed that when I post an entry from there, WordBooker doesn’t seem to pick it up and post it to Facebook. I went into my WordPress install proper, added a space to the end of the entry, overrode the “Force Re-Publish” setting and re-saved. Facebook picked it up right away.

    Is this just something that happens as a result of using blogging clients instead of doing things directly from the WordPress posing interface? Do you have any control over how the plugin behaves in that regard?

    For purposes of comparison: Twitter Tools used to behave the same way, but changed at some point and seems to pick up MarsEdit-posted entries just fine.

    I tested it with a few XMLRPC clients under linux and Vista and it seemed to work fine.

    You have got “publish by default” checked?

    Well, I thought I did earlier, but I disabled the plugin when it looked like it wouldn’t work, then reenabled it and had to go through and reconfigure it as a result. I was careful to check “publish by default” this time. It worked on my next post. Must have missed that setting the first time.

    Thanks for the quick response!

    Glad it worked

    I tried enabling it on one blog and it worked, but on another one everything seems ok from a configuration standpoint , but it doesn’t post anything with facebook. Is there a way to log/trace what/if wordbooker does something when I post a post ?

    Are there any other facebook related plugins enabled for that blog? Is it dumping anything into its own error logs (which show when you go to the options page) or into the php error logs?

    I am having a problem with Wordbooker 1.6.1 in that it threw up the “Hey, you’re not allowed in here.” message whenever a non-admin user tried to login. And when I go to the Settings, I get the following error:

    Fatal error: Uncaught exception 'FacebookRestClientException' with message 'Incorrect signature' in /home/sustaio8/public_html/wp-content/plugins/wordbooker/facebook-platform/php/facebookapi_php5_restlib.php:3112 Stack trace: #0 /home/sustaio8/public_html/wp-content/plugins/wordbooker/facebook-platform/php/facebookapi_php5_restlib.php(1794): FacebookRestClient->call_method('facebook.users....') #1 /home/sustaio8/public_html/wp-content/plugins/wordbooker/wordbooker_options.php(112): FacebookRestClient->users_getLoggedInUser() #2 /home/sustaio8/public_html/wp-includes/plugin.php(339): wordbook_option_manager('') #3 /home/sustaio8/public_html/wp-admin/admin.php(95): do_action('wordbook_option...', Array) #4 /home/sustaio8/public_html/wp-admin/options-general.php(10): require_once('/home/sustaio8/...') #5 {main} thrown in /home/sustaio8/public_html/wp-content/plugins/wordbooker/facebook-platform/php/facebookapi_php5_restlib.php on line 3112

    This is really a cool plugin but I just had to deactivate it to allow my users to be able to log in and post.

    Can you please help?
    Thank you, jim

    The hey you’re not allowed message is all changed in 1.7 – which sets some different levels for different users.

    The “Incorrect Signature” error is down to a failure in the power supply to the Facebook back end ( http://developers.facebook.com/live_status.php#msg_570)

    It should now be working again

    When will 1.7 be around? I’d really like to try it out but can’t right now, because my users have no access to the dashboard anymore with Wordbooker enabled. Looks like a really nice plugin though.
    Thanks, Mike

    As an interim fix, I just commented out the offending IF statement and all is well, especially for users other than admin. Looking forward to the new version.

    1.7 should be out next week – I pushed another Beta out this morning.

    The security thing is going to be a big change – some people want to lock it down, some want it open, some want it very configurable and I suspect that its going to be something that needs a lot of looking at and work on.

    For example if someone doesn’t have a FB profile associated with their account but the blog admin has set it up to post to say his account then should it still do it if the person posting the entry doesn’t have wordbooker set up.

    Hi All,

    Trying to activate Wordbooker 1.7.2 on WP 2.9.2. Just upgraded our server to PHP 5.2.12 because I thought our lame 4.something or other version was the problem. I’m getting this fatal error:

    Parse error: syntax error, unexpected '{' in \\boswinfs01\home\users\web\b469\ywh.ivyroomchicagocom\blog\wp-content\plugins\wordbooker\wordbooker.php on line 134

    Any ideas? Thanks,

    Matt

    Matt, if you’re getting that error then its still running on php 4.x (which doesn’t understand the try { } catch { } logic )

Viewing 15 replies - 1 through 15 (of 85 total)
  • The topic ‘[Plugin : Wordbooker] Bug reports’ is closed to new replies.