WordPress.org

Forums

[Plugin: Wordbooker] 60 character limit on post attribute? (9 posts)

  1. tranified
    Member
    Posted 4 years ago #

    Was just curious why there was a 60 character limit on the post attribute (when on the Edit screen of a post).

    There doesn't appear to be a limit when posting a link to Facebook, so I'm wonder if there was a specific reason?

    60 characters isn't a lot to describe the post and encourage people to read it. Any way to remove that limit? Or at least make it longer?

    Thanks,
    -Alex

    http://wordpress.org/extend/plugins/wordbooker/

  2. Steve
    Member
    Posted 4 years ago #

    The post attribute is just supposed to be a little tag line as a sort of "pre-amble" to the post itself. So "Has written something on his blog" for example. The "body" of the wall post is the first few 100 characters of the post itself (but I will be adding the ability to use the WordPress Post Excerpt text in there instead.

  3. jgentes
    Member
    Posted 4 years ago #

    Just another comment on this - I tried teh excerpt feature, and it replaces the actual content, which is different from what the post attribute does. I'd like to have a longer title, which poses a question to the users, followed by the actual content snippit that normally comes from the blog post.

    I'm going to dive into the code for the plugin to see if I can find '60' anywhere in there to increase it, but I'm not a developer so we'll see how it goes :)

    Thanks for the plugin, it rocks!

    -James

  4. jgentes
    Member
    Posted 4 years ago #

    Looks like it's in wordbooker/wordbooker_options.php

    echo '<label for="wb_attribute">'.__("Post Attribute"). ' : </label>';
    echo '<INPUT NAME="wordbooker_settings[wordbook_attribute]" size=60 maxlength=60 value="'.stripslashes($wordbooker_settings["wordbook_attribute"]).'">
    ';

    The same text seems to be in there four times, of course I'm not sure why, but I replaced '60' in maxlength for each of them with '240'.

    Looks like it works, I'll post back here if I run into problems.

  5. Steve
    Member
    Posted 4 years ago #

    The options screen is there in two versions for different versions of WordPress. So that is why you found it more than once.

  6. jgentes
    Member
    Posted 4 years ago #

    I noticed these settings get blown away when updating the plugin, which is a real bummer. Any chance this could be added as an option?

    Or better yet, why not just increase the maxlength of this field? There really is a totally legitimate reason to do this - check out my facebook posts at http://facebook.thesocialbusiness.com - these come from the blog and I add a blurb about each one. Why limit it to 60 chars? I don't understand why that would be necessary.

    Thanks!

    -James

  7. Steve
    Member
    Posted 4 years ago #

    I can look into changing the length of the attribution field. Its something that probably just fell between the cracks when I was changing things.

  8. hughhempel
    Member
    Posted 4 years ago #

    Hi Steve,
    I would also vote to either allow the user to set this limit OR simply increase the number of characters to at least 250... really no reason to limit in my mind...

    Great plugin! Thanks for you work!

  9. Steve
    Member
    Posted 4 years ago #

    I'd actually changed it but missed one of the maxlengths ;-)

    Line 881 in wordbooker_options.php has a maxlength set to 60 when it should be 240.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags