WordPress.org

Support

Support » Plugins and Hacks » WooCommerce » [Resolved] [Plugin: WooCommerce] Woocommerce Pretty Permalinks

[Resolved] [Plugin: WooCommerce] Woocommerce Pretty Permalinks

  • I am hoping to get some help with my permalink setup in woocommerce.

    I typically use the ‘pretty’ permalink structure of /%postname%/, but this breaks my catalog setup and returns a 404 error. I have even tried combinations such as /%category%/%postname%/, /page/%postname%/etc. but nothing works.

    When i set my permalinks to the WP default, the catalog works perfectly, but my other non-catalog pages, such as ‘Company Info’ and ‘Contact Us’ have the crappy permalink [hxxp://mysite.com/?p=123] which looks horrible and is even worse for SEO.

    I would ultimately like my site structure as follows:
    For my catalog: hxxp://mysite.com/mens/pants/bushmaster-cargo-pants (not too picky about this URL structure)
    For my static pages: hxxp://mysite.com/company-profile (MUST have ‘pretty’ permalink)

    I am using WP 3.2.1 (until the theme dev updates for 3.3 compatibility) and Woocommerce 1.3.2.1

    I also have Yoast WordPress SEO v.1.1.2 and WooCommerce – All in One SEO Pack 1.1 installed.
    Tried the ‘Canonical URL’ setting under the ‘Advanced’ tab in Yoast, still no luck.

    Any help would be most appreciated. Have a great day.

    http://wordpress.org/extend/plugins/woocommerce/

Viewing 15 replies - 1 through 15 (of 18 total)
  • I don’t know exactly if we have the same issue, but since I upgraded to the new WooCommerce-version my product-category links are broken. I had this error before:
    http://wordpress.org/support/topic/plugin-woocommerce-ecommerce-plugin-for-wordpress-category-view-is-broken

    hi,
    i have the same problem.

    I activate the permalinks from woocomerce, i activate permalinks from wordpress and when i go to a product the url is changed with a nice link, but i get 404 error.

    Everything else from wordpress is working….

    What to do?

    Thank you,
    tj

    I made a thread about the exact same thing earlier today. I emailed Woocommerce and they.. don’t seem incredibly interested to fix the issue. I really need to do this for SEO reasons. I have a blog on my site as well and the url should be “/blog” but I can’t obviously.

    Guys. please comment on vote here. Let woocommerce know we need this.

    http://woo.uservoice.com/forums/133476-woocommerce/suggestions/2560413-we-need-support-for-pretty-permalinks

    Hi guys, i fixed it.
    When you activate permalinks, to work this, you need to be sure that in .htaccess file are these lines:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Good Luck!

    EDIT: nvm this does not work

    whoah looks like I lied. my cashe just wasn’t updated. Adding that will not fix the issue.

    The admin of woocommerce just declined the vite saying they do support pretty permalinks.. even though all of us are having the issue

    I added the modual provided by WordPress to my .htaccess file. It makes no sense.

    The blog and posts show up fine. When you look at products at the shop they 404. and if you go to edit the products, and click “view” it will link you straight to the 404

    I was able to get it working with the following settings:

    htaccess – I did not modify that file at all.
    Wordpress Permalink Settings – custom structure > /%category%/
    Woocommerce – Settings > Pages Tab > Permalinks > Product base page > Prepend product permalinks with product category *TICKED*

    Currently the site is WP 3.2.1 and Woocommerce 1.3.2.1
    The theme I am using was recently upgraded for WP 3.3.x and Woocommerce has released WooCommerce 1.4
    Not sure if things will go blooey when I upgrade but I will report back once I give it a shot.

    Good luck everyone.

    Finally a working answer. Fantastic work. Thank you so much.

    I’m trying to do a eCommerce website using WooCommerce plugin (Version 1.4.2) and WordPress (Version 3.3.1). But my permalinks are not working at all. –> http://www.fillettesetfistons.com/

    If you click on the Categories (sidebar) it gives me a “No products found which match your selection.” even if there is a product inside of that category.

    Can someone help me?

    Thanks!

    I’m having the exact same problem as everyone above and GoElemental’s solution didn’t work for me either… I’ve tried updating my htaccess a couple different ways and nothing’s helped.

    Using WP 3.3.2, WooCommerce 1.5.4, and Wootique 1.3.1.

    Thank you GoElemental — totally fixed my 404 problem!

    Another big big Thank you to GoElemental – upgraded Woocommerce and it totally threw out all of the products with a 404 error. The sheer panic was only relieved by following GoElemental’s advice step by step.

    Phew, sanity restored!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] [Plugin: WooCommerce] Woocommerce Pretty Permalinks’ is closed to new replies.
Skip to toolbar