WordPress.org

Support

Support » Plugins and Hacks » WooCommerce » [Resolved] [Plugin: WooCommerce] Slider not working on Wootique

[Resolved] [Plugin: WooCommerce] Slider not working on Wootique

  • I have searched for the solution to this problem, but to no avail.

    I have Wootique installed as the main theme of my storefront. No matter what I try, I cannot get the slider/static portion of the home page function.

    Anyone else with this issue? Anyone have a possible fix?

    Thank you in advance.

    Cheers,
    Stefani

    http://wordpress.org/extend/plugins/woocommerce/

Viewing 15 replies - 1 through 15 (of 27 total)
  • I have tried to look at the source code for the demo site and compare it to mine, and the difference is that the demo calls forth this:

    <div id="featured-products" class="fp-slider">
    		<h2>Featured Products</h2>
    
    		<ul class="featured-products">
    
    			<li class="flipper">

    and mine does not, even though I have the slider selected.

    In addition, with a blank home page, there is no slider called forth either. I have manually inserted short codes to get the featured products to show.

    http://lizzieandrewborden.com/HatchetOnline/hatchetstore/

    Any help or advice would be greatly appreciated.

    Oh, BTW, I set up a fresh install and the same problem happens. I am using Powweb as my server.

    Plugin Author Mike Jolley

    @mikejolley

    Ensure you have latest versions of both the theme and framework – I believe there were some patches related the the slider.

    BTW if you have bought any WC extensions you’ll have access to the Woo forums where you’ll get better support than over here 🙂

    Lizzie, I have the same problem.

    Just found the problem. It´s a version error.
    You have to edit the index.php
    Change this:

    ?>
    
    	<div id="featured-products" class="<?php if ( get_option( 'woo_featured_product_style' ) == 'slider' ) { echo 'fp-slider'; } ?>">
    		<h2><?php _e( 'Featured Products', 'woothemes' ); ?></h2>
    
    		<ul class="featured-products">
    <?php
    $args = array( 'post_type' => 'product', 'posts_per_page' => get_option( 'woo_featured_product_limit' ), 'meta_key' => 'featured', 'meta_value' => 'yes' );
    $loop = new WP_Query( $args );
    while ( $loop->have_posts() ) : $loop->the_post(); $_product = &new woocommerce_product( $loop->post->ID );
    ?>
    			<li class="flipper">

    for this:

    ?>
    
    	<div id="featured-products" class="<?php if ( get_option( 'woo_featured_product_style' ) == 'slider' ) { echo 'fp-slider'; } ?>">
    		<h2><?php _e( 'Featured Products', 'woothemes' ); ?></h2>
    
    		<ul class="featured-products">
    <?php
    $args = array( 'post_type' => 'product', 'posts_per_page' => get_option( 'woo_featured_product_limit' ), 'meta_key' => '_featured', 'meta_value' => 'yes' );
    $loop = new WP_Query( $args );
    while ( $loop->have_posts() ) : $loop->the_post(); $_product = &new WC_Product( $loop->post->ID );
    ?>
    			<li class="flipper">

    [Please post code or markup snippets between backticks or use the code button.]

    Thank you for this. I tried it and I still do not have the slider. Any other suggestions?

    I did update the framework today and that didn’t work either.

    Cheers,
    Stefani

    It´s a theme update, download it and re-install and it is probably going to work. Don´t forget to change settings to activate the slider of course.
    Are you sure you changed woocommerce_product for WC_Product at the index.php?
    For me it works now… keep on looking for something in the code.
    Anyway, your shop is already nice and working.
    Congrats.

    I did the theme update, downloaded it, and re-installed.

    I changed the settings to activate the slider.

    I changed woo commerce_product for WC_Product at the Index.php.

    Is it my browser?

    One question—-you say to change the settings to activate the slider. What settings are you referring to? The pages section of Wootique offer me either a slider or a static display of featured products. There really isn’t an on/off switch for the slider. Correct? Or am I missing something?

    Thanks in advance!

    I know I am using a free theme and a free plugin to get my sale site operational, but is there any way for you, mikejolley, to assist me in making the theme that woo commerce created work?

    It would be greatly appreciated!

    Cheers,
    Stefani

    Still having the same issue. Am I the only one?

    Fixed it. If you select a static page as your main page in Settings–>Reading, instead of Your Latest Posts, you lose the slider. Simple solution.

    @stefani

    Thank you for this information, I have been looking and looking for a solution and yours is the best one I found. Had no idea it was the static page causing the problem. Thanks!

    @stefani this is so frustrating still not working on mine! site

    I am having the same problem, but my Settings are already set to display my latest posts.

    Anybody have any insights on this?

    Wootique 1.0.2, Framework 5.3.12, WordPress 3.3.2.

    do you have give star at your product? its options to chose product be a featured product

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] [Plugin: WooCommerce] Slider not working on Wootique’ is closed to new replies.
Skip to toolbar