SEO Questions after upgrade (6 posts)

  1. Geetar
    Posted 4 years ago #


    Just after upgrade to the last version of WooCommerce and Wootique I noticed that there are 2 custom fields called seo_follow and seo_noindex with the value "false".

    Since then, none of the new added products have been indexed by Google. I didn't touch anything related to SEO since the initial setup.

    These custom fields have a direct relation with search engines indexing or it's just that Google didn't visit the website?



  2. Mike Jolley
    Plugin Author

    Posted 4 years ago #

    I think you may just be impatient :)

    Those fields are used by some SEO plugins - the reason you've never noticed them before is pre 1.4 the custom fields panel was hidden.

  3. Geetar
    Posted 4 years ago #

    Almost 3 days later and Google hasn't indexed any of the new products on my site. This happened after upgrade.

    Results appear on Google as "mysite.com/checkout/order-received/" and as text of related products of stuff that was already indexed by Google before the upgrade i.g: "mysite.com/shop/another-product/. New products URLs are not indexed.

    Looking at the source code all seems ok: <meta name="robots" content="index, follow" />

    Using WooTique 1.2, WooCommerce 1.4.1 and framework v 5.1.6.

    I own many WordPress websites and Google index the sites quickly, some of them in under 3 minutes.

  4. joleneb
    Posted 4 years ago #


    Can someone give me an answer to this. If I want Google to index my site do I set:

    seo_follow = false
    seo_noindex = false


    seo_follow = true
    seo_noindex = true

    I can't seem to find a straight answer to this online anywhere :(


    PS: this is a "custom fields" setting I also noticed on each individual product page of my woo-commerce site... would I have to change them all individually, if they *do* need to be changed?

  5. Daluxe
    Posted 4 years ago #

    A short explanation:

    Follow = Search enginges should follow the links on the site and inherit linkjuice...
    noindex = Search enginges SHOULD NOT index the website.

    So if you want your sites to be indexed and followed, your settings should be:
    seo_follow = true
    seo_noindex = false


  6. joleneb
    Posted 4 years ago #

    Thank you so much for this!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic