[Plugin: Woocommerce] problem displaying "Add to Cart Button" variable Product (13 posts)

  1. mexican_chilli
    Posted 2 years ago #

    Hi, I'm experiencing problems at the moment with Woocommerce variable products, Everything worked like a charm do far, but I don´t know how to display the add to cart button after I'm choosing a variation of the product, what I know so far is that the problem is caused mainly because of Gantry theme, I already tried with Twenty Eleven and some other simple templates, I would like to be able to solve the problem without having to replace Gantry, it´s our base template for our job, an nd my Boss' favourite teplates.

    Any help would be appreciated.

    My regards

    test site
    WP 3.2.1
    Gantry 1.25

  2. bwedmonds
    Posted 2 years ago #

    Same here. There's a bunch of talk out there about fixes, but nothing that seems to work for me. Anyone have new ideas other than updating to, JQuery 1.7+ and clearing cache?
    Thank you!

  3. Sjobidoo
    Posted 2 years ago #

    Using Woocommerce here and also tried clearing cache..but still no luck.

    No "add to cart" button on any of the variable products.

    I've mad sure that prices on each variables are set etc.

  4. sparklyscotty
    Posted 2 years ago #

    I had the same problem and tried multiple steps:

    • clearing cache
    • ensuring that the js files are there (apparently they went missing for some folks)
    • following the (overly precise) steps in the right order to add variations
    • turning stock control on and making sure stock amounts were added to each variable
    • ensuring that each variable had a price
    • Creating a default variable
    • de-activate all plugins

    It was the last item that got me, as I was trying to call jQuery scripts from Google's library for a fancy entrance effect for an image. Looks like it conflicted with WooCommerce calls to scripts.

  5. Sjobidoo
    Posted 2 years ago #

    Solved it by using the sollution mentioned in this thread. Seems the variable products JS wasn't being loaded for some reason...

  6. Phillip
    Posted 2 years ago #

    Hi there,

    Desperate to fix this! Please help!

    The site has been working perfectly but now variable product is disabling the AJAX animation that reveals the Add to Cart once size is selected.

    The site is: http://mattillidge.phillipvale.com.au/

    Any help would be much appreciated,


  7. @Phillip Please start your own thread instead with your own details.


    Your problem while similar is not the same as the OP.

  8. BillionaireBum
    Posted 2 years ago #

    Hey Guys

    I seem to be having this issue all of a sudden. It literally happened out of nowhere. No new plugins or changes. It only happens witha a variable product. A simple product seems fine though. I have followed the above steps but to no avail. Thinking about doing a complete re-install and database dump at this rate.


  9. Sjobidoo
    Posted 2 years ago #

    @BillionaireBum : You've added prices for your variable products I assume? Do you have a link to your site perhaps so I could take a look?

  10. BillionaireBum
    Posted 2 years ago #

    It seems to be a theme problem as all works perfectly with the default theme. I think there was an update and that caused the issue.

  11. Sjobidoo
    Posted 2 years ago #

    There's a JS error if you look in console:

    "Uncaught TypeError: Cannot read property '153' of undefined. ( add-to-cart-variation.min.js:3 )"

  12. BillionaireBum
    Posted 2 years ago #

    Any idea how to fix it? Excuse my lack of knowledge.

  13. ilya12
    Posted 2 years ago #

    The same have happend to me after installing a new plugin and some other manipulations with attributes. 'Add to cart' button for variable products have stopped showing up after selecting a variation.

    I have tried several advices with no luck.

    I was lucky to finally fix it by simply updating to from woocommerce 2.0.9 to 2.0.10

Topic Closed

This topic has been closed to new replies.

About this Topic