WordPress.org

Forums

WooCommerce - excelling eCommerce
[resolved] [Plugin: WooCommerce] fatal error when trying to delete plugin (13 posts)

  1. Andrea Fercia
    Member
    Posted 3 years ago #

    just tried version 1.4
    deactivate plugin: OK
    but *delete* plugin gives: Fatal error: Call to undefined function woocommerce_get_page_id() in {my installation path} /wp-content/plugins/woocommerce/uninstall.php on line 24
    thx
    Andrea

    http://wordpress.org/extend/plugins/woocommerce/

  2. Mike Jolley
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks, Ill fix it up.

  3. sebastiencyr
    Member
    Posted 3 years ago #

    Got the same problem, investigating...

  4. sebastiencyr
    Member
    Posted 3 years ago #

    I added this line in uninstall.php above the calls

    include_once plugin_dir_path(__FILE__) . 'woocommerce-core-functions.php';

    this loads the woocommerce_get_page_id() and was able to uninstall correctly.

  5. Andrea Fercia
    Member
    Posted 3 years ago #

    thx Mike,
    I noticed also the "skip_install_woocommerce_pages" option doesn't get deleted when you uninstall, maybe you should consider to change in your uninstall.php:
    $wpdb->query("DELETE FROM $wpdb->options WHERE option_name LIKE 'woocommerce_%';");
    with:
    $wpdb->query("DELETE FROM $wpdb->options WHERE option_name LIKE '%_woocommerce_%';");

    there are also some postmeta and some comments (used as order statuses?) you should consider to remove upon uninstallation and maybe also some capabilities assigned to admin.
    A great plugin should really clean up things :-)
    thx
    Andrea

  6. salsatrips
    Member
    Posted 3 years ago #

    same issue: 1.4 doesn't work anymore (checkout button without function), layout destroyed (text overlays, arrangements; was better before 1.4). Now it's not possible to delete the plugin. Any help would be appreciated. Thx

  7. salsatrips
    Member
    Posted 3 years ago #

    Sorry, it's even worse: deactivating woocommerce or deleting it via ftp means that all my pages won't load anymore! Anybody any idea? Thank you!

  8. Mike Jolley
    Member
    Plugin Author

    Posted 3 years ago #

    @salsatrips your theme may need a few tweaks if its custom but thats it...

  9. salsatrips
    Member
    Posted 3 years ago #

    Hi Mike,

    You wrote that my theme may need a few tweaks or may need to be updated, but that's it...

    I have looked into woocommerce with several developers and we couldn't fix the issues. Last night we even rebuilt the complete multisite from scratch, but still face the same issues - like others, too.

    Now my challenge is that - even going back to 1.3 via ftp - the checkout button is not working anymore. Furthermore the styling got broken (text overlays the buttons, fields are not aligned; both looked MUCH better in 1.3 than in 1.4).

    This means suddenly I can't use the shop anymore, even not, using my workaround with a normal page with "add to cart" buttons instead of the product list.
    http://www.freiburg-salsafestival.com/ticket-shop

    The other page is a different multisite for testing with a blog, just for woocommerce - no other plugins activated. Very tricky, but we made it to put even the product list into the content box, but also here "add to card" is not working anymore:
    http://woo.1sofa.eu/shop/

    Would be great if you could look into this directly or agree to a small project to fix the issues, as that would help others, too. In case, I can provide access to one or the other multisite, too.

    Thank you

  10. Mike Jolley
    Member
    Plugin Author

    Posted 3 years ago #

    You need to look in WooCommerce > Settings > Pages - I don't think your checkout is setup correctly at all.

  11. salsatrips
    Member
    Posted 3 years ago #

    OK, I replied on the other thread already. It's obvious that woocommerce doesn't work with Thesis and other themes. V1.4 is worse than before.

    Please let me know in case of any interest to get this running. Thx.

  12. streightdesign
    Member
    Posted 3 years ago #

    After installing the woo commerce plug-in I have lost access to our entire site. No matter WHAT we do in wordpress I only get this message:

    Fatal error: Call to a member function get_image_size() on a non-object in /home/content/66/9351166/html/wp-content/themes/Sommerce_Premium_WordPress_Theme/sommerce/inc/woocommerce.php on line 192

    we cannot view our site, make any edits, nothing. We even activated a different theme and then after trying to delete the sommerce theme, it went right back to this fatal error message. HELP!

  13. Mike Jolley
    Member
    Plugin Author

    Posted 3 years ago #

    You need to contact the theme author.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic