WooCommerce - excelling eCommerce
[resolved] WooCommerce outsetting "noraml wordpress page IDs&q (2 posts)

  1. billabong74
    Posted 3 years ago #


    I installed all the necessary plugins to run WooCommerce Multilingual.

    As far as I can tell until now it seems to be running well.

    (Twenty Eleven standard WordPress (child) Theme)


    I am using the RoyalSlider to display different slideshows in my header section. In oder to show the right slider in the right place I am using a function inside my header.php. (function: if is page X get slider Y).

    NOW THE PROBLEM: WooCommerce seems to be outsetting my page IDs leading to an empty header (no slider showing!).

    The problems occurs on the following "sites/pages):

    - the page that is set to be the "shop base page"
    - the product page (when an individual product was chosen/clicked)

    When getting to the "cart" page the slider is showing perfectly!

    I guess the problem does not exist when opening "true pages"....and occurs when one opens "untrue pages" like that "mixture" of a true page and the shop base page....and the product section!

    Any clue as how to resolve this???

    To be seen here (no picture and no logo(image) showing in header!):





  2. Mike Jolley
    Plugin Author

    Posted 3 years ago #

    WPML creates multiple pages for each localisation - thats your problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.