WordPress.org

Support

Support » Plugins and Hacks » WooCommerce » [Plugin: WooCommerce – excelling eCommerce] Checkout button not showing on Woo commerce product

[Plugin: WooCommerce – excelling eCommerce] Checkout button not showing on Woo commerce product

Viewing 15 replies - 16 through 30 (of 82 total)
  • If I were you, I would add the Cart widget in the right column only on this page. This way your visitors will see their shopping cart all the time!

    If I were you, I would add the Cart widget in the right column only on this page. This way your visitors will see their shopping cart all the time!

    Not sure if we’re talking about the same thing here…

    I was referring to the “Add to cart” button…not the shopping cart / contents itself.

    i meant also the add to cart button….
    and @siteground this is also set it is strange that when i set it to variable the “add to cart” button is gone.

    @myloomedia: sorry..was referring to SiteGround’s comment 🙂 Added quotation for clarification 🙂

    My first answer was for keithkranc (about the Cart widget). I have a live website running with a lot of variable products without any issues. Have you tried re-creating your items? First, save them simply as variable products, then add the Attributes and make sure the “Use for variations” check is checked, save again and then add the attributes as variations. Finally, save again. Sometimes, attributes don’t get saved, or you do too many changes in one save and things get messy…

    Tried recreating the products from scratch as you mentioned without any luck unfortunately. Also checked that the attributes are actually saved. They show up in the select list on single product view…but nothing happens when changing the value of the select list…no add to cart button :/

    Se example here

    same here

    Thank you Siteground – that widget worked for showing the cart and checkout on the Shop page.

    -Keith

    I also have a couple other issues now on checkout. How do I remove the “terms and conditions” section?
    http://screencast.com/t/P2S15XUEequ

    And I am also getting a message that there are “no available payment methods for my state” and the billing address information above automatically filled out all the fields with my client’s information – his address and phone number. And I didn’t even enter that information. He told me it is doing the same thing for him. (He is in Louisiana and I am in Washington)
    http://screencast.com/t/v3fVXlXPa9f

    @sjobidoo and @myloomedia, I am afraid that without the login details I cannot fix this. I asked Keith to mail me the credentials but then it turned out that that’s against the rules.

    The only thing I can think of without having access to the admin area is that you have Stock enabled for those items. If so, you need to enter a number in the Quantity field to have the Add to Cart button displayed.

    tell me how to contact you ?

    [ Moderator note: This forum does not provide support via email. ]

    Please make me screenshots of the General, Variations and Attributes tabs for this product. I am afraid that I cannot give yo my email address since that would be against the forum rules. However, I will do my best to assist you with that issue.

    Here’s the screenshots:

    General

    Attributes

    Variations

Viewing 15 replies - 16 through 30 (of 82 total)
  • The topic ‘[Plugin: WooCommerce – excelling eCommerce] Checkout button not showing on Woo commerce product’ is closed to new replies.
Skip to toolbar