WordPress.org

Support

Support » Plugins and Hacks » WooCommerce » [Plugin: WooCommerce – excelling eCommerce] Checkout button not showing on Woo commerce product

[Plugin: WooCommerce – excelling eCommerce] Checkout button not showing on Woo commerce product

Viewing 15 replies - 1 through 15 (of 82 total)
  • Hello,

    I think that you have created a Variable product but didn’t enter prices for all the variations you’ve set for that product (Quantity 1,5,50,100). If you want the same price for all variations, open the product, go to the variations tab, click the Add variation button and select Any Quantity. Finally add price for the product and the Add to Cart button will be rendered.

    Hristo
    [ Signature moderated. ]

    Thank you. It is a variable product, because people can buy the wristband 5 different options of quantities that we have chosen.

    I went into the variation settings and all the pricing I had already set was gone. They all showed zero, so I added pricing back into each variation. After that the shopping cart showed up again at the bottom of the description (because of shortcode) but the add to cart button is still missing.

    Hello,

    I totally agree that this could be a bit less confusing. All could be easier if there was an AJAX-powered Save button.

    First, you need to go to the Attributes tab, add the ones you need, mark the Used for Variations and optionally Visible on the Product Page and then hit the Update button at the top-right part of the page. That will cause the page to reload with the saved attributes.

    Once you have active attributes for the product, go to the Variations tab. In your case, you can simply click the Link All Variations button. Then enter prices for all variations and hit the Update button once more. The Add to Cart button should appear on your shop page now 🙂

    Add to cart button is there now but now the prices are showing $0 in the cart. (And The prices used to show correctly) I am getting this message when I click add to cart http://screencast.com/t/dVl7yHSw

    And the cart checkout section that I added with a shortcode does not even show up in Safari.

    Make sure that you have prices set for all of the active product variations. I think that you’ve added a variation without price and the system cannot calculate the overall product cost due to that reason.

    I thought I had prices set. Here’s a video of the admin http://screencast.com/t/pS6IANUra

    If I were you, I would change the product type back to Simple and hit update clearing all associated Attributes and Variations. Then simply add them again. Maybe something went wrong triggering a bug. I am afraid that I cannot tell more without looking at the actual admin area but setting the product anew seems to be the best approach.

    I just did that and it didn’t seem to work. Would you possibly be able to log in and take a look at it? I will pay you for it.

    Thank you,
    Keith

    Hello,

    Send me your login details at [email address moderated – this forum does not provide support via email] . No need to pay for that, mate 🙂

    Awesome thank you! I just emailed you….

    Fixed 🙂

    In woocommerce/woocommerce-functions.php I have commented out the following lines:

    // Only allow integer variation ID - if its not set, redirect to the product page
    //if (empty($_REQUEST['variation_id']) || !is_numeric($_REQUEST['variation_id']) || $_REQUEST['variation_id']<1) {
    //	$woocommerce->add_error( __('Please choose product options&hellip;', 'woocommerce') );
    //	wp_redirect(apply_filters('woocommerce_add_to_cart_product_id', get_permalink($_REQUEST['product_id'])));
    //	exit;
    //}

    This seems to be a bug that will be fixed in the next release according to the plugin author and his comments in GitHub 🙂 I now made a new product and placed an order successfully. To test the entire process I had to add a payment method. I enabled Payment on Delivery because it’s the easiest one to test!

    Best of luck with your website!

    Thank you very much I appreciate it!!

    -Keith

    Hi-

    I changed up the way added these products. I created a separate product for each quantity pack and it works much better now.

    But I have another question – on http://www.pdda.org/shop how do I get the Proceed To Checkout button to show up if someone clicks “add to cart” from that page? I tried adding the shortcode but it isn’t looking right.

    If you click on the product first then the add to cart and checkout work fine, but not from the Shop page.

    I’ve tried the above sollution myself with no luck.

    Using WooCommerce version 1.6.5.2 and no “Add to cart” button appear on any of my variable products. Prices are set on all variables…

    Also tried commenting out the above code from woocommerce-functions

    Sjobidoo,

    Got the same problem it seems a bug.
    If i set to variable the cart button disappeers

Viewing 15 replies - 1 through 15 (of 82 total)
  • The topic ‘[Plugin: WooCommerce – excelling eCommerce] Checkout button not showing on Woo commerce product’ is closed to new replies.
Skip to toolbar