WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WooCommerce – excelling eCommerce] "Add to Cart" not displaying after choosing op

[Resolved] [Plugin: WooCommerce – excelling eCommerce] "Add to Cart" not displaying after choosing op

  • After upgrading to 1.6.1, like the title says, after choosing a variation from the dropdown, the rest of the form is never displayed. Including the “Add to Cart” button. A pretty nice feature for an online store.

    I had a backup of 1.5.8 and downgraded to that. Everything is working now.

    I had this problem previously with 1.5.8 and fixed it by unchecking the box in WooCommerce > Settings > General “Output WooCommerce JavaScript in the footer”. That option is now unavailable in 1.6.1

    Just thought I’d alert Woocommerce of the problem.

    http://wordpress.org/extend/plugins/woocommerce/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author royho

    @royho

    I am not seeing this issue with 1.6.1. But it sounds to me like you have some kind of JS conflict on your site. Try checking your console log on page load to see if you see any errors.

    Am having the same issue but don’t have a previous version of WooCommerce to try the downgrade. I am using the Ultimatum theme. Another Ultimatum user has indicated that the previous version of woocommerce works fine.

    Here is the site with the issue:
    http://www.poshjewelrysolutions.com

    Royho,

    It’s a custom theme I’ve built.

    I would leave a link, but I’m busy developing on a localhost. After installing 1.6.1, I checked the console, no errors. I even tried deleting all JS, including the typekit links. I tested in Chrome, Safari, Firefox, and Opera. No dice.

    It does work when when I switch themes to TwentyEleven.

    So, the only thing I can think is that I’m missing something. I have wp_head();. Is there anything else that is crucial for this plugin to work?

    Thanks for the response, btw.

    Plugin Author royho

    @royho

    Yeah unfortunately it is hard to help if I cannot see the site.

    Plugin Author Mike Jolley

    @mikejolley

    wp_footer() is needed too – we removed the JS in the footer option because we now always output JS in the footer (its more efficient).

    http://codex.wordpress.org/Function_Reference/wp_footer

    I am having the same issue as davidrupper
    I updated from 1.6.1 to 1.6.5.1 and the “add button” do not appear in the product page… my site is nicotine.soulblu.co.nz

    Please advice on what to do — Urgently!
    THanks

    Hey guys…

    I finally finished developing on the localhost and the site is live.

    I have the plugin updated to 1.6.5.1 and I’m having the same problem. Can’t seem to pinpoint a problem through the console.

    I’ve tried disabling all plugins and even deleting all my javascript… Nothing.

    Check it out here:
    http://www.superfluentdesign.com/shop/

    I’ll be leaving the updated version up until Monday, we’re planning on announcing the new site on Tuesday (9-4), so if I can’t get it resolved by then, I’ll just have to revert back to 1.5.8.

    Thanks in advance.

    PS:
    I forgot to say “Thanks!” for the awesome/free plugin you guys developed. It’s highly appreciated.

    Plugin Author Mike Jolley

    @mikejolley

    Either:

    – old jquery version
    – wp_footer() missing from theme
    – javascript conflict – check console

    I had the same problem and found it caused by js conflict around using the jquery $

    the solution is adding the following line into all the conflicted function
    var $j = jQuery.noConflict()

    and then substitute all the instances of $ with $j

    Hope it helps!

    Hi, I have been going back and forth with this for 5 days. Would anyone mind looking @ http://www.anabolicthreat.com/shop/at-7-3/ as an example. I cannot get the add to cart to show. Even when I manually remove the display: none from the div to make it appear
    <div class=”single_variation_wrap” style=”display: none;”>

    I get the message “Please choose product options…”

    I have tried these as well.
    – old jquery version
    – wp_footer() missing from theme
    – javascript conflict – check console

    Your help is greatly appreciated.

    I see you managed to resolve this puradavidboy.

    You seem to have had the exact same issue as me 🙁 please can you tell me how you manage to resolve this.

    Thanks in advance

    @puravidaboy could tell me how you fixed the problem.

    Thanks dude

    Sorry for the delay. It was a plugin/Javascript conflict. I thought I had disabled the plugins which is what was driving me nuts, but I had forgot to activate a plugin called “Affiliately” – and solved

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] [Plugin: WooCommerce – excelling eCommerce] "Add to Cart" not displaying after choosing op’ is closed to new replies.