WordPress.org

Support

Support » Plugins and Hacks » WooCommerce » [Plugin: WooCommerce – excelling eCommerce] Add to cart button not showing

[Plugin: WooCommerce – excelling eCommerce] Add to cart button not showing

Viewing 15 replies - 1 through 15 (of 16 total)
  • URL please?

    On a general note, make sure that your products pricing is set up properly, go through the product properties and make sure that everything is set up right. If you the WooThemes Demo Site, you will see that the Add to Cart button is also missing, so you have to make sure your product is set up properly. You may also want to review the page below:
    http://wcdocs.woothemes.com/category/user-guide/admin-user-guide/settings-admin-user-guide/

    I will let you know if I think of anything else.
    Cheers,
    Munny1

    http://www.brad-scott.com/?post_type=product

    I posted the link before and it didn’t work. Here it is again.

    Ahh, I see your issue. What you need to do is edit your product. Check all of the product tabs and make sure that everything is set up properly. A common mistake is to change the type of product when it should not be changes. It looks like in your case that for a tshirt, you want a VARIABLE PRODUCTS.

    In short, read the docs below carefully, they will help out very much:
    http://wcdocs.woothemes.com/user-guide/product-variations/

    Let me know if you get it to work.
    Cheers,
    Munny1

    Still no luck. Followed those instructions step for step and have checked every setting several times over. Am I able to give you access to the site so you can have a look for me?

    Plugin Author Mike Jolley

    @mikejolley

    You have no variations…

    var product_variations_2070 = [];

    Well, for a variation product to work, it needs variations! @smallo add some variations (see docs)

    Trust me, variations are there.
    LOOK HERE

    Plugin Author Mike Jolley

    @mikejolley

    Expand them so I can see them.

    Also, you may want to switch to the default theme to see if thats affecting it, and turn off other plugins to check for conflicts. The page is not outputting those 3.

    Ok so I just tried Turning off all plugins except WooCommerce and tried going back to the twenty ten and twenty eleven themes with still no luck. Here is a picture of the variations expanded.

    Plugin Author royho

    @royho

    Ok if you have opted to use the attributes as variations, in your attributes tab under, you must check “Used for variations” checkbox for it to show.

    It is ticked. Is anyone willing to go in my site and have a look for me? I’ll give someone temporary Shop Manager access.

    Plugin Author Mike Jolley

    @mikejolley

    Looks like you gave up already. nvm. I cannot say why they were not being queried correctly – can’t reproduce anywhere else.

    IO think I have the same problem.

    I am using a StudioPress theme.
    I have set up a Product with two variations.
    When I go to the live page, and select one of the variations, the ‘Add to Cart’ button (+ # of items, etc.) doesn’t show up.

    View here:
    http://www.kairoscanada.org/shop/seeking-shelter/

    I came across a discussion of the same prob on this forum:
    https://github.com/woothemes/woocommerce/issues/1514

    In it they ask, “Do you have wp_footer(); in your themes footer.php page?”.
    Genesis (StudioPress core theme)*does* have wp_footer(); in the theme, so I’m stumped.

    Any ideas??

    Thanks.

    NIk @ KAIROS

    My add to cart button won’t show via mobile devices. I had to install WordPress Mobile Pack because my website wouldn’t show via mobile devices without it. I tweaked the CSS and got everything looking decent only to have someone tell me they couldn’t check out because the add to cart button won’t show. Any ideas as to what I should do?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: WooCommerce – excelling eCommerce] Add to cart button not showing’ is closed to new replies.
Skip to toolbar