Support » Plugins and Hacks » WooCommerce » [Resolved] [Plugin: WooCommerce – excelling eCommerce] Add to cart button missing

[Resolved] [Plugin: WooCommerce – excelling eCommerce] Add to cart button missing

Viewing 15 replies - 1 through 15 (of 20 total)
  • Nevermind, figured it out



    Hi crepusculae,

    I am having the same problem, but can’t seem to find the awnser. Can you tell me how you fixed it?

    Thanks in advance,



    Please let us know how you fixed it as I’m having same issue

    Thanks in advance!

    Ace Troubleshooter


    I’m having the exact same problem. Will someone please help us!!!



    The issue I found was that Cloud Zoom was enabled at the same time. Which is really kind of ridiculous given it’s supposed to work in tandem with the product slideshow, but — once I disabled it the button was back.



    Just rolled back to previous version of Woocommerce and buttons started working fine!



    I am having the same problem with a product I set up with variations. Where do you find the Cloud Zoom settings?

    Ace Troubleshooter


    Just fixed the add to cart missing button issue I was having. I was told that plugins are a common factor for this type of problem, so I deactivated them all (except woocommerce) and switched themes to 2011 (default wordpress theme). I activated them 1 by 1 to narrow down which plugin was causing the trouble. Not sure how, but after reactivating them all, my add to cart button appears just fine and it looks as if the issue resolved itself. So switching out of my theme, deactivating plugins (except woocommerce!!!), reactivating my theme and reactivating my plugins fixed it. Not sure if this will work for anyone else, but I thought id offer the example seeing as how this problem is stupid annoying. And everyone remember that you have to select an option (size, color, ect) before the add to cart button will appear!

    Just a note… you MUST define a price for the product (in the Product Data -> General ->Regular Price ) before the add to cart or other options appear.

    My add to cart button is missing. It displays a small section, but not a full button or text.


    Any ideas? thks

    I have a new responsive theme with the newest updated WooCommerce plugin, and yet the ‘Add-To-Cart’ button does not show up on simple or variable products until you refresh the page. This is also true of the FB Like and Pinterest ‘Pinit’ buttons on the product page(s).
    Some sort of javascript / jquery problem. Does anyone have a clear answer?

    Really can’t diagnose without a URL… What is your ‘new responsive theme’?

    Hi I have the same problem, ADD to Cart is nor visible. I just update the plugin but remains same.


    The missing button happen to me also. I thought that I had change something in the php file, but can’t find any. So I got suspicious that only the css changed.
    Checking with firebug and safari, I found out that the display is set to hidden. I change it (on the browser) to block, the button showed.
    The problem is, I can’t find the css tag in any file in the woocommerce folder and subfolders.
    Anyone know where I can find it?

    Roy Ho


    @rahyrs – it is hidden for a good reason and I don’t recommend you to unhide it as you will have problems such as people being able to add to cart without selecting any variations.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] [Plugin: WooCommerce – excelling eCommerce] Add to cart button missing’ is closed to new replies.
Skip to toolbar