Support » Plugin: WooCommerce » [Plugin: WooCommerce] Check out Not worknig

  • Resolved lasanmuditha


    I installed the plugin and develop the e store . I selected the paypal as my default payment gateway and entered the paypal email address as well But when i click the checkout, check out page open with blank. how can i fix this and connect to my payment gate way.your help is very much appreciated,
    thanks in advance

Viewing 15 replies - 1 through 15 (of 80 total)
  • Plugin Author Mike Jolley


    Check your pages are set up correctly in Woocommerce > Pages. You may also need to turn off force ssl on Woocommerce > settings.

    I’m having the same issue. My Checkout page is blank. The pages seem to be set up correctly, and Force SSL is unchecked. I’m wondering if there’s additional some setup I need to do in my PayPal account. Is my PayPal email really the only thing I need to enter into the WooCommerce settings?


    Got it.

    Mikejolley, I found your post in the WooCommerce forum that mentioned how the pages should actually be set up — with a shortcode on each page. First I’ve noticed that mentioned anywhere. The shortcode for each page is listed on the setup page for WooCommerce.

    For whatever reason, the shortcode for my checkout page was not there when I checked. I inserted it, and now everything works fine. Just wanted to post that here because as a newbie, this was not something I thought to check.


    I am having a similar issue … except all my short codes are there

    Even with all info entered the spinning wheel for the checkout part just keeps spinning and never becomes live.

    i have a site which works fine but when i go on to the checkout it loads and then i fill in all the info and then click place order and it just has the little loading circle and i have left it running over night but no luck and i cant find any one else with the same issue as me. please help me

    it is on a test server ATM.

    please help me

    My checkout page is not working– all I get is the page with no content and a the shortcode shows up:

    But doesn’t do anything.
    @sixfive.creative it looks like you figured it out.

    I’m guessing I didn’t fill out something in the settings but I can’t tell what it is as everything else is working.

    Think I might have it. I have no idea why but the shortcode on my “checkout” page was automatically set as [shoppingcart]. I deleted it, changed it to [woocommerce_checkout] by using the dropdown icon for woo.

    Me too, here are the problem in wc debug:
    Cart Page Page does not contain the shortcode: [woocommerce_cart]
    Checkout Page Page does not contain the shortcode: [woocommerce_checkout]
    Pay Page Page does not contain the shortcode: [woocommerce_pay]
    Thanks Page Page does not contain the shortcode: [woocommerce_thankyou]
    My Account Page Page does not contain the shortcode: [woocommerce_my_account]
    Edit Address Page Page does not contain the shortcode: [woocommerce_edit_address]
    View Order Page Page does not contain the shortcode: [woocommerce_view_order]
    Change Password Page Page does not contain the shortcode: [woocommerce_change_password]

    Now I don’t know what to do with that, and i will very please to see your help.

    Checkout works fine to me right after I installed Woocommerce 1.5.5 few days ago. Yesterday, I tried it again, but it just has a little loading circle and never stop. I found there is a update version, so I deleted mine and activated 1.5.6, but the problem is still the there.
    I cannot place order, even I switch theme to Twenty Eleven.
    I check all pages created by Woocommerce. They all have shortcode, except Shop page.
    Has anyone found the solution yet?

    hi i found out that you need to make the checkout page the parent of your pay page and change the make of the of the page “Checkout → Pay” and it should work.

    I currently have the same issue my site is set up correctly and up to date but once you get to the checkout page in the Paypal section there is just this spinning loading circle that lasts forever.

    I’ve searched high and low for a solution but to no avail.

    If anyone can shed some light on this it’d be greatly appreciated.

    right send me your site url and il take a look at it. you should go to your pages and change the name of the pay page to “Checkout → Pay” and place checkout as parent. i did this and mine seem to work.

    hi mmediadesign, I check my pages. Here is the pages’ structure. I haven’t made any change yet. It seems the structure is correct. Did I miss any part?
    – Checkout → Pay

    By the way, I set Direct Bank Transfer as payment gateway.

    it seem to be in the right placed. have you placed all the pages in the right order in the woocommerce settings?
    – Checkout → Pay
    this is what my pages are set up like
    Cart Page – Cart

    Checkout Page – Checkout

    Pay Page – Checkout → Pay

    Thanks Page – Track order

    My Account Page – My Account

    Edit Address Page – Edit Address

    View Order Page – View Order

    Hey mmediadesign, I just tried to checkout on your site and you still have the same error I have. As soon as the Checkout page loads, the Paypal section never finishes loading, just keeps on spinning.
    What’s even more interesting is you’re using the same theme as me. So maybe it’s a theme issue?

    I tried your page naming trick but no luck.

Viewing 15 replies - 1 through 15 (of 80 total)
  • The topic ‘[Plugin: WooCommerce] Check out Not worknig’ is closed to new replies.