Support » Plugins » [Plugin: WooCommerce] Cart broken/not adding products

  • I’ve yet to get Woocommerce to add any product to my shopping cart. It redirects me to the page and displays “Your Shopping Cart is Empty”.

    I’ve tried everything and I can’t figure out why it won’t add products to my cart.

    Has anybody else had this problem or know a fix? I just updated to the newest woocommerce (1.5.1) and still nothing.

Viewing 12 replies - 46 through 57 (of 57 total)
  • Just run into this issue. All worked fine and all of the sudden it started to empty then cart. Then it would work fine for a few minutes only to start bugging again.

    It turns out that server had no more disk space left on /tmp. Session data is written there.

    I tried this in shell (hosted at Webfaction):

    df -h

    There should probably be no “100%” anywhere. If there is it’s a good bet that’s what is causing problem.

    Support ticket is away, waiting reply…

    Yup, full /tmp directory was my problem, fixed by the host.

    Pulling my hair out – I add products to my cart and then when I go to view cart is says cart is empty.

    Here is the site
    http://lululuna.com/

    Can anyone say how they fixed this? I see a lot of different solutions, and problems on this thread.

    I’m thinking it may be a hosting issue /tmp?

    Any help would be appreciated my site is useless right now.

    Ahhh I also have this problem and the site was working just fine before.

    Sometimes the cart works and sometimes it doesn’t this just recently happened. When I click on “ADD-TO-CART” it will say it’s added it to the cart and sometimes when I click on another Item and I click “ADD-TO-CART” it will make the other item disappear. Or when I click “ADD-TO-CART” and then I go on the right had corner and click on the cart image. It will take me to the cart but it will be an empty cart. And sometimes the cart will work.

    What to do? What to do?

    I’m not sure if this just fixed my site but the cart is actually working now. I’ve put 20 items and it hasn’t cleared..

    This is a long shot but idk..

    Try clearning the Transients in WooCommerce > Settings > go all the way to the bottom and you’ll see “Clear Transients”

    POSSIBLE FIX:

    Had this same issue. My issue stemmed from the fact that I have multiple domains pointing to the same website (ie. mywebsite.com, myawesomewebsite.com). Sometimes there are redirection issues where when you press the Add to Cart or Proceed to Checkout it tries to jump between the two domains. This causes a security issue with Javascript (annoying but for good reasons).

    I fixed this by adding a permanent redirect with my host and also by going into the wordpress settings and making sure the domain urls are set to my primary domain (CAUTION: IF YOU PUT IN THE WRONG DOMAIN IT WILL LOCK YOU OUT OF YOUR WORDPRESS AND THEN YOU WILL HAVE TO FIX IT THROUGH THE CONFIG FILE). I also had to go into my database and change the home url to my primary domain.

    Hope this helps!

    What solved my issue was changing my PHP to v 5.2. Previously it was configured to 5.3.

    • I had tried all of the other presented solutions in this thread
    • Changing (shop) permalink
    • Changing Themes
    • Disabling all other plugins
    • Disabled ajax
    • Verified no other JS issues or PHP errors

    Added to cart, checked cart and nothing was there…

    I did what snuniyar said above and will elaborate a bit:

    1. Checked the system status on WooCommerce.
    Click “WooCommerce > System Status and then look for red text.

    2. Noticed my PHP Session save path was missing.
    Red text “/var/php_sessions does not exist – contact your host to resolve the problem.”

    3. Called my hosting provider to fix the path.
    I had to do the chat messaging thing with iPage

    4. Now everything is working fine.
    Indeed, added to cart and it’s still there when i check the cart page.

    Hope this helps! 🙂

    To all those who is having problems adding products to cart…If you click add product to cart and it shows it but when you go to cart and it’s not there read on…

    Itis all about your PHP. To be precise change your php from suphp to mod_php and you will be fine. I have switched the hosts( I use VPS) and set the php to run as suphp and everything was working fine BUT woocommerse. Took a while but I changed php to mod_php and all is peachy.

    Some here in the thread reported contacting support of your hosting…It will work as well. I am using Kloxo to host my sites so it was just a matter of switching server program.

    Cheers!

    For those using W3 Total cache, I recently updated W3 Total Cache to v0.9.2.8 and Woocommerce to v2.0.1 and the database caching was creating empty shopping carts. For now I have turned it off.

    Apparently Woo has set their pages to “DONOTCACHE” ( http://docs.woothemes.com/document/configuring-caching-plugins/ ) but it stopped working for me with the upgrade.

    As per Sean – everything appeared to work smoothly before upgrade – upgrade appeared to go smoothly also but started to recieve empty shopping carts – deactivating W3 has sorted this out for now.

Viewing 12 replies - 46 through 57 (of 57 total)
  • The topic ‘[Plugin: WooCommerce] Cart broken/not adding products’ is closed to new replies.