Support » Plugins and Hacks » [Plugin: WooCommerce] Cart broken/not adding products

[Plugin: WooCommerce] Cart broken/not adding products

  • I’ve yet to get Woocommerce to add any product to my shopping cart. It redirects me to the page and displays “Your Shopping Cart is Empty”.

    I’ve tried everything and I can’t figure out why it won’t add products to my cart.

    Has anybody else had this problem or know a fix? I just updated to the newest woocommerce (1.5.1) and still nothing.

Viewing 15 replies - 16 through 30 (of 57 total)
  • brithulsizer


    My issue was directly related to the Gravity Forms add-on. I had it redirecting, and that was causing the error. It needs to be just set on “text”.

    This worked for me. Set your browser to accept cookies!! Finally worked for me

    Let me also say, I followed all of the advice given above especially about PHP Sessions.

    @brithulsizer, where can we change the setting to “text” like you mentioned? Please explain, thank you.

    Anyone else have a fix? When I click “SUBMIT”, nothing gets added to cart and the product page just reloads minus the GF forms.

    I noticed that if you input a regular price for the product under the standard woocommerce field (in product edit), the add to cart button reappears, BUT, now there are TWO prices shown on the product page. One is the woocommerce static price and the other is the variable price generated by Gravity Forms. HELP!

    in my php.ini the
    was not orrecly set to /tmp
    on my vps server

    problem fixed

    i think we’re looking at a lot of different problems here. but i am experiencing an “add to cart” failure only on macs (hate those buggers) specifically in Safari. I checked the cookies, but from the code I’d think the biggest reason that the add-to-cart function would fail is an empty $_REQUEST variable.

    Please ensure your browser accepts cookies and javascript is enabled. Worked for me

    Cookies are critical. 🙂 also, personally my issue was related to a bug in the 1.7 beta… SESSION variables weren’t quite being set properly. Has been fixed by the awesome Woo team.

    Other potential causes could be a caching plugin causing your JS to break. This killed my checkout actually until I figured it out and didn’t minify the checkout page. Make sure to check your console for JS errors. (F12 in chrome launches the developer tools.)

    Hi, I have this problem too. Form fills out, calculates price, and when you click ‘Add to cart,’ it does not add to cart, just refreshes page.


    Any help appreciated, thanks.

    James, did you verify the issues already raised in this thread? Cookies? Broken javascript? I can tell in 2 seconds by pressing F12 in chrome that you have javascript issues, so that could be a factor.

    Hi, cookies are working fine, the only JS error I get is this, which I don’t think is related, but maybe someone could translate for me?

    Failed to load resource: the server responded with a status of 404 (Not Found) http://mamacocoasdelights.com/product/assorted-truffles-test/custom


    That isn’t a JS error, though I don’t know what it is. I see the following 2 JS errors:

    [cycle] terminating; zero elements found by selector jquery.cycle.all.min.js:1
    FB.getLoginStatus() called before calling FB.init(). connect.facebook.net/en_US/all.js:52

    so I would consider disabling some plugins to see if you can isolate further.

    As usual in these cases, I recommend you disable all plugins and then re-enable them one at a time. Also, You might need to remove everything you’ve customized in your functions.php and then add it back slowly too. Sorry, I cannot be more specific without digging into your code for you.

    PS- it is really hard to look at your site when I’ve given up sugar for a few weeks!

    Thank you, I’ll try that with the plugins, always a good bet. Much appreciated.

    I got the same error. My site is

    It was running without any problem until today. session.save_path is correctly set to /tmp, cookie and JS are being enabled. Tried to disable plugin but it did not help.

    Any ideas?

Viewing 15 replies - 16 through 30 (of 57 total)
  • The topic ‘[Plugin: WooCommerce] Cart broken/not adding products’ is closed to new replies.
Skip to toolbar