Support » Plugins » [Plugin: WooCommerce] Cart broken/not adding products

  • I’ve yet to get Woocommerce to add any product to my shopping cart. It redirects me to the page and displays “Your Shopping Cart is Empty”.

    I’ve tried everything and I can’t figure out why it won’t add products to my cart.

    Has anybody else had this problem or know a fix? I just updated to the newest woocommerce (1.5.1) and still nothing.

Viewing 15 replies - 1 through 15 (of 57 total)
  • Most common cause – PHP sessions aren’t set up correctly on your server (hosting issue).

    Same issue here.
    It worked perfectly fine before but now is broken.

    Did anyone solve this problem? Would this help?

    Checking the session.save_path directive in php.ini It must be a folder writable by the server in order for sessions to be saved.

    If anyone found a definitive solution, could you post it?

    Thanks

    I am having this problem too, “Your cart is currently empty”, and according to WooCommerce system status “/var/lib/php/session is writable” so it does not seem to be PHP Sessions issue…

    soflaweb

    (@soflaweb)

    This problem just appeared for me as well.
    It was working fine about a week ago.
    I am just starting to troubleshoot now, and this thread was at the top of my search results.
    Has anyone found a resolution in the woothemes support forums possibly?

    AN ANSWER: I too had this problem. Then it occurred to me I was logged in as ADMIN. So I used a different browser as an end user and the cart worked fine! That COULD be the problem I, like many of you, experienced.

    I actually resolved my issue by contacting my host.
    Something had happened with an upgrade via Plesk control panel and one of the configuration files was missing from the root folder.
    I am sorry that I do not have more information, it was several weeks ago that this was resolved and I do not recall the details.
    The one item to take away is that, for my issue, it was not WordPress or WooCommerce. It was a server issue.

    I had this same problem.

    I was running PHP on my CentOS / Plesk server as a FastCGI application – so changed it to run PHP as an Apache module and it solved the problem.

    I’m having the same issue. Any solutions yet?

    I do have gravity forms installed with the WooCommerce add-on, and am unsure if this may be affecting it, but definitely need to solve the issue. I have contacted Woo Support, but no response yet.

    I seem to have the same kind of problem. Add-to-cart problem does not seem to appear when clicked from admin account, but from other account, the ajax animation appears zand nothing. The product doesnot seem to update in cart. Please post a solution to this problem.

    Just had the same

    My cart could not be found even though it had been added!

    Checked my settings and found…

    WooCommerce > Settings > Pages
    ——————————————————————-
    X Prepend product permalinks with shop base page (shop) Note: The shop page has children – child pages will not work if you enable this option.
    ——————————————————————-

    This was ticked!!! Unticked it and all is fine again!

    I must be having a different issue. I just tried that solution, and it did not work for me.

    My site will go to the cart, it just does not display the products that have been added…just shows empty.

    I’m also having problems with the AJAX if you could help.

    The payment and add to cart do not work.

    However it works fine when i am logged in.

    Any ideas?

    Test Page: http://jessieharris.co.uk/product-template

    I am having the same issue here. I have all my pages defined under Woocommerce Pages, System status under Woocommerce also shows everything green, I have the right shortcodes in all my pages. But I still gets an empty Cart when I try to checkout. Any Help?

    This happens whether I am logged in as admin or guest.

Viewing 15 replies - 1 through 15 (of 57 total)
  • The topic ‘[Plugin: WooCommerce] Cart broken/not adding products’ is closed to new replies.