Support » Plugin: WooCommerce » [Plugin: WooCommerce] Adding product categories is broken

  • Resolved shyytia

    (@shyytia)


    I installed WooCommerce 1.3.2.1 and couldn’t anymore add Product Categories. When I tried to add a new category I got the following error:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 19456 bytes) in /public_html/wp-content/plugins/woocommerce/admin/writepanels/writepanels-init.php on line 212

    Before that I got another error from /plugins/woocommerce/admin/writepanels/writepanels-init.php on line 55, which I managed to resolve by disabling SKUs from the WooCommerce settings.

    Only solution for me was to downgrade back to WooCommerce 1.3.2, which resolved all these problems.

    http://wordpress.org/extend/plugins/woocommerce/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Turned out that the since new plug-in requires more memory from the server, few modifications to the php.ini and htaccess solved the problem.

    Following lines were added to
    php.ini:

    memory_limit = 64M
    post_max_size = 20M
    upload_max_filesize = 20M

    htaccess:

    <IfModule mod_suphp.c>
    SuPHP_ConfigPath /home/USERNAME/public_html/
    </IfModule>

    Plugin Author Mike Jolley

    (@mikejolley)

    Could have used this also: http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Memory usage is improving in 1.4 (in development).

    tongny

    (@tongny)

    Hi mike!
    I use woocommerce now, but one problem is that i cannot retrieve the category with image.
    Can you guide me to view all product category with its image?

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WooCommerce] Adding product categories is broken’ is closed to new replies.