Support » Plugin: Disqus Comment System » Plugin won’t save my API Access Token

  • I’ve filled my site’s Shortname, API Public Key, API Secret Key and API Access Token in Disqus’ “Site Configuration” tab, but although the page refreshes and say everything was saved, when I leave it and go back, the API Access Token field is blank again.

    Because of that, I can’t enable Sync features.

    Help.

Viewing 15 replies - 1 through 15 (of 19 total)
  • I dunno if this is super helpful, but I had to do a hard refresh of the admin options page to get the keys to show up.

    I think they were there and the disqus backend thout they were there, but they just weren’t showing up due to some caching issue.

    YMMV, maybe wholly unrelated, etc.

    Yeah, that’s not the case @johnreeve. Thanks.

    I’ve actually went back to the configuration page and all the fields are now blank.

    I also see an error on the top related to an invalid “nonce” cookie or something, which I’ve seen before on Jetpack’s plugin and found out it has to do with a conflict between Jetpack and the WordPress SuperSonic with CloudFlare plugin.

    However, I’ve also tried disabling the Supersonic plugin and, although the cookie error goes away, I still can’t save all the configuration fields inside Disqus.

    Sorry that wasn’t a solution. That’s very similar to what I was seeing yesterday, but likely a different issue. I think that there are some funky local cache issues with this.

    Right now I’m trying to troubleshoot how to modify the JS vars to customize them… I can’t tell if I am dumb or if the plugin is poorly documented, but I guess I’ll just re-read the code again LOL

    best of luck on finding a solution.

    One day later, now the “Site Configuration” fields are all appearing as filled. Don’t know what happened.

    However, when I click “Enable Auto Syncing”, I get a “There was an error attempting to enable syncing.” on the top. Doesn’t say what, exactly…

    Plugin Contributor ryanv12

    (@ryanv12)

    @rfischmann Is your site https by chance? Our backend has had some trouble connecting to sites that are listed as https but don’t have a certificate.

    That might also explain the nonce/cookie issue you saw randomly earlier, as a cookie marked as “secure” wouldn’t be available to regular http connections.

    @ryanv12 Yes, our site is running on HTTPS but it does have a valid SSL certificate and it’s running on “Full (strict)” mode at Cloudflare.

    Plugin Contributor ryanv12

    (@ryanv12)

    What’s the domain, so I can try looking it up on our end?

    @ryanv12 macmagazine.com.br

    Thanks!

    [ Please do not bump. ]

    Just updated to 3.0.13, nothing changed. The plugin is still useless for us.

    Updated to 3.0.14, still bad.

    Just making sure you guys are aware, no bump: 3.0.15 still hasn’t fixed my issues. Can’t use the new plugin.

    I believe that I’ve found a pattern on this. If I access the admin page without https, the plugin works fine. If I change to https, I begin to fail and shows the mentioned issue.

    @rafaeltoledo Yes, @ryanv12 asked about HTTPS above. But our site isn’t even accessible without HTTPS anymore, so they need to fix that on their end.

    hello, I’m having the same exact problem on my webiste.
    “There was an error attempting to enable syncing.”
    Have the latest version of the plugin and yes, my website is HTTPS.

    Any suggestion pls??

    I figure it out finally. To solve the problem make sure that the “Permission” are setted to : Read, Write, Manage Forums

    I created an application with just Read, Write, but to make it work you need to set Manage Forums as well.

    Hope it helps 🙂

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Plugin won’t save my API Access Token’ is closed to new replies.