Support » Plugin: BackUpWordPress » Plugin won’t activate, says I need to meet requirements I already have

  • Resolved Chelsey


    Every time I try to activate the plugin, I get this message:

    BackUpWordPress requires PHP version 5.3.2 or later and WordPress version 3.9 or later to run. It has not been activated.

    My site meets the requirements. I contacted my host, they said they can’t figure out what the problem is. I have PHP 5.4.43 and I use Bluehost, if that helps.

    I have two sites. The plugin works fine on one of them. I’m only having a problem on

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author katmoody


    Hey there – do me a favor and look at the list of plugins for troubleshooting we have up on our site, and check out the last one there – the phpinfo one. Install that and see if the values match what you and the host think they are. Let me know either way so I can either signal the developers for more troubleshooting or so we can check more with your host.


    Hey Kat, thanks for the response!

    I installed it and it says my PHP version is 5.2.17. How do I fix this? When I contacted my host to double-check, they said there was no problem and that their information was correct.

    But, as I said, my other site that’s on the same host is having no problems with the plugin. Is there a reason one site would have a different PHP version than the other?

    Plugin Author katmoody


    That would be a question for your host – but I would suggest checking to see if the php version is declared in the htaccess file. Sometimes it is, and it can cause issues if the settings aren’t the same as what’s actually on the server.

    Hi Kat,

    I took a look at the htaccess file on the site, and I do not see any explicit declaration of my PHP version (as in a hard-coded “your version is 5.2.17). Ctrl-f finds no instance of 5.2.17, for example. Moreover, nothing that I can see in there suggests it might be causing that issue.

    My cpanel indicates that my php version is 5.4.43, and my conversation with bluehost indicated that nothing is wrong on their end, unless I am just not verbalizing this issue correctly. That’s definitely possible, but it still leaves this discrepancy.

    Do you have any other thoughts, by chance? I really appreciate the help so far!

    ETA: I ran the plugin on my other site, hosted under the same account with bluehost. phpinfo() gives me a version number of 5.4.43, which is correct. Are there any sources you know of besides the htaccess file that can cause such an issue?

    • This reply was modified 3 years, 10 months ago by Chelsey.

    Quick followup. I found this command in the htaccess file:
    Redirect 301 /xmlrpc.php

    which appeared to be causing the explicit PHP version declaration. Removing this command in the htaccess file causes PHPinfo() to display the correct information.

    Will it be alright to leave this command out from here on? It has a comment that says to use for performance reasons

    Plugin Author katmoody


    So that bit of code redirects all requests to the XMLRPC to the requestor. This was likely done because XMLRPC attacks still sometimes occur with WordPress sites and this is like turning their misdeeds back on them. But XMLPRC also controls all pingbacks and other such goodness. So redirecting the hits like this shouldn’t always be the first response.

    If you never need to use this file for remote connections to your WordPress site, you can deny all access to it, using a different htaccess rule, like so (search and confirm the use for your host before using!):

    <Files "xmlrpc.php">
    Order allow,deny
    Deny from all

    Or you can use a plugin that controls access to the xmlrpc file (I believe there are a few of them).

    I’m not positive why that rule by itself would have caused problems but try those solutions and see if either of them help you out, okay?


    OK. Thanks for the help!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Plugin won’t activate, says I need to meet requirements I already have’ is closed to new replies.