Support » Plugin: Polylang » Useful plugin with some problems

  • This plugin is good but it has bugs (or maybe it is not stable), that make it difficult to use it. I have the problem that it is not possible to reach the default homepage, it always redirects to the second language. This is an issue that many other users have experienced but the developers don’t care about it (that is still my impression). I know that this is free software but even free software should work properly, like other free plugins do and you get support from the developers.

    At first the plugin worked ok but after migrating the site to another server (or after the last WordPress Update to 5.2.3), the problems occurred and whatever setting I used in the settings panel nothing worked, the default homepage was gone.

    Meanwhile I have found out, that transients might play a role (https://wordpress.org/support/topic/homepage-redirect-problems-solved/), so maybe there ist some caching problem which should be mentioned in the documentation. I say this because I have never experienced something like this and I have migrated many different websites

    Edited: 2019-09-24 and changing the rating from one to three stars

    • This topic was modified 4 months ago by Svensson36.
    • This topic was modified 4 months ago by Svensson36.
Viewing 6 replies - 1 through 6 (of 6 total)
  • @svensson36 You wrote the plugin was working until you moved your website to another server. Neverthelss you think the plugin has a bug? You should think about if you did something wrong. Why else should a plugin work until you have changed basic things?
    Maybe your request here was not worth to answer. You are using a plugin for free and you expect help from the community but you don’t care to give all the necessary information that people can answer in their spare time.

    @thecoder Maybe my english is not good enough, but I wrote that I know that the plugin is free, here I wrote just a review. And at this place (the review section) I did not expect help. But it should be possible to post a review without getting a rude answer.

    I know that I did not do anything wrong because I have moved so many website to other servers and every time the result was perfect but not here with this plugin – and the issue with the default homepage has of course something to do with the plugin

    And I wrote that I am not the only one who has experienced this issue, see for example here: https://wordpress.org/support/topic/polylang-redirects-to-secondary-language/

    So maybe something is wrong with the plugin.

    As you wrote, @svensson36 , the plugin is working on a lot of websites. So, why do you give only a 1 star review?
    I assume it is your frustration because you are not able to fix the problem. It is probably easier to blame the plugin than to admit that you can not solve the problem.

    I know your post, because I read every post here. But I do not invest my spare time to help someone who does not invest his oder her time to give the necessary information.

    The author of Polylang has invested hundreds of hours and provides his plugin for free. It is a way of respect not to expect he is working for you. You should also invest your time to find out what is wrong on your installation instead blaming he or the community for missing support.

    I am not expecting the author of the plugin is working for me. And I never wrote something like that. And I am never blaming the community for missing support. So what’s your problem?

    If your spare time is so important why are you wasting it with replying to reviews?

    I think I am allowed to give as many stars as I want. And that I am not the only one who experiences this problem can you also see here: https://wordpress.org/support/topic/homepage-auto-goes-back-to-second-language/

    And: When there is a solution for this problem, I would give the plugin another chance.

    @svensson36 Again, you are using the rating of the plugin to blame the pluign for something you have to take care about.

    I think I am allowed to give as many stars as I want.

    This is unsocial. If you respect the work of an open source developer you do not give “many stars as you want”. You have to be fair and rate the trues.
    The trues is: The plugin is working but after you changed something (the server) you are not able to get it up and running. The problem is on your site.

    Let’s end this discussion because it does not make sense. You simply ignore the fact that many other users have exactly the same problem.

    To be honest: the problem occurred already on the old server but there I could fix it. So it has nothing or little to do with the new server.

    Wheather I am fair or rate the trues that is not upon you to decide!

    What is your problem? There are many positive reviews an some bad, that’s quite normal.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this review.