Support » Plugin: Microsoft Azure Storage for WordPress » [Plugin: Windows Azure Storage for WordPress] plugin doesn't connect with blob storage

  • Resolved mfaria


    When I’m working at localhost, the plugin works fine.
    But, when I’m at the windows azure, I can’t upload files to the blob storage. It shows the error message bellow:

    “testing.jpg” has failed to upload due to an error
    The uploaded file could not be moved to E:\sitesroot/wp-content/uploads/2012/02.

    It’s trying to upload some file to my aplication directory instead of the blob storage.
    Does anyone knows what’s going on?

    Marcos Faria

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hello,

    I’ve got the same problem. Current stable version of wordpress and windows azure storage plugin.

    Does anyone have a solution?

    It looks to issue permission settings.
    The plugin will upload the file to Azure Storage after upload the file to wp-content on local storage.
    Check permission to modify wp-content on local storage.

    At Windows Azure environment, you can add permission at start-up.


    I solved my problem. Problem was the WordPress Tempdir. On Windows Azure, set upload and temp path to an local ressource.

    /** Set UPLOADS path **/
    define('BLOGUPLOADDIR', azure_getlocalresourcepath('<LocalStorageName>'));

    I’m having this problem too.

    in your BLOGUPLOADDIR, are you setting <LocalStorageName> to something? Or is that a literal that I would put in there. And this goes in the wp-config file?

    <LocalStorageName> ist the name of your LocalRessource defined in your ServiceDefintion Configuration. My solution only works on an Windows Azure VM or in the Windows Azure Emulator.

    I just set up a site on Azure, but I’m getting the same error whenever I try to upload an image to display in a post.

    “start_example.png” has failed to upload due to an error
    The uploaded file could not be moved to E:\sitesroot/wp-content/uploads/2012/04.

    If the problem is a folder permission thing, then is there a way to fix it as a start up job when deploying?

    There’s actually a discussion over at

    It is a permissions issue as I sort-of resolved my issue after updating the permissions. Essentially, you’re going to change the install-php-impl.cmd file to say:

    CALL icacls %RoleRoot% /grant “NETWORK SERVICE”:F /T

    I haven’t yet confirmed this. I manually changed permissions using Remote Desktop to the azure instance. Once I changed permissions, I no longer got the error you’re showing. I started getting a different error which I’m working on now.

    If you make that change and confirm it works, please let us know.

    I fixed it with teamsavoy’s help. I added this line to the install-php-impl.cmd file as suggested.

    CALL icacls %RoleRoot% /grant “NETWORK SERVICE”:F /T

    After upgrading my deployment I was able to save my image file to my blob storage account. I can use azure storage explorer to view the wpsync container and my image is in there. I can now include it in my blog. Thanks for your help, teamsavoy.

    The issue should be fixed with the port to the latest Windows Azure SDK for PHP.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Windows Azure Storage for WordPress] plugin doesn't connect with blob storage’ is closed to new replies.