Support » Plugin: Cloudflare » Plugin Will Not Activate

  • raven747

    (@raven747)


    Having issue activating the plugin. When I try, it simply just does not. It is the only plugin that will not activate.

Viewing 8 replies - 1 through 8 (of 8 total)
  • lukelol

    (@lukelol)

    Also facing an activation issue.
    Unable to interact with the settings for CloudFlare.

    requests to:
    /wp-admin/admin-ajax.php?action=cloudflare_proxy&proxyURL=zones&proxyURLType=CLIENT
    result in this response:
    {"result":null,"success":false,"errors":[{"code":"","message":"Forbidden"}],"messages":[]}

    jondaley

    (@jondaley)

    My plugin activates, but gives a blank page (other than the wordpress menu, etc) when going to the settings page.

    The request to:

    /wp-admin/admin-ajax.php?action=cloudflare_proxy&proxyURL=config%2F&proxyURLType=PLUGIN

    returns 0 in the HTML and a 400 server response.

    jondaley

    (@jondaley)

    Ah – found another post – I had to disable W3 total cache plugin entirely in order to get the cloudflare settings page to load.

    Gal Baras

    (@galbaras)

    If you’re using Cloudflare APO, you may not need W3 Total Cache anymore. Either way, instead of deactivating it completely, you can disable it for logged in users, or at least for users with your role (administrator, I’m guessing).

    jondaley

    (@jondaley)

    Yeah, I was wondering about that. For now, I’ve turned off the APO, because I’m not convinced it is that useful in my scenario. The most interesting part was about the third party libraries, and I don’t see any changes there. And the HTML can’t be cached for almost any of the pages due to the way the theme was written. I might need to find out more about what the APO can do, since for some other sites I’ve written, where I do cache all of the HTML, and then dynamically change bits via Javascript, I don’t really think I need APO there either, because I have Page Rules that heavily cache everything, so there are very few hits to the origin.

    Gal Baras

    (@galbaras)

    Sounds like you have a paid plan. Why not consult Cloudflare Support on this directly?

    jondaley

    (@jondaley)

    heh, that’s funny. I just googled for the answer and found a couple threads here about the issue and hadn’t thought about asking them… I usually hate it when companies make me go to the community forums and don’t do support. Thanks.

    yevgens

    (@yevgens)

    Here are the list of things APO is capable of: https://support.cloudflare.com/hc/en-us/articles/360049822312

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Plugin Will Not Activate’ is closed to new replies.