Support » Fixing WordPress » [Plugin: WikiPop] I’ve been observing a problem with the animation of Wikipop

  • GimliGlider

    (@gimliglider)


    Dear plugin author,

    First thing first, I don’t know of the appropriate words to properly express my gratitude for the plugin you’ve written. It has saved me hours because if I had to manually link words to Wikipedia entries, it would be way too cumbersome and time-consuming. So thanks so much for your contribution!

    Secondly, I’ve been observing a peculiar problem and it occurs in both 2.7.1 and 2.8 too, and only in Mozilla Firefox. Whenever I click on the link, the window pops up, but the animation gets garbled. I’m not saying the framerate of the animation isn’t smooth, but it’s just not what I want it to be.

    In opera, IE8, IE7, IE6, safari, chrome and any other browsers, the animation works as expected and as has been defined by FanyZoom’s author. But only in Firefox it starts out with a blank white window, then as the window moves, everything becomes garbled. The window fixes itself when content from wikipedia finishes loading.

    Once again this doesn’t happen in any other browser, only in Firefox.

    I hope you’d look into this soon

    The example can be found at http://www.gimliglider.com U’ll see the problem if you open that address in Firefox. Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • lankybutmacho

    (@lankybutmacho)

    I do see what you mean. I’ve noticed that the animation’s a little stilted in some browsers too, although it seems particularly bad on your site. It may have something to do with the fact that there’s quite a lot of javascript running on your page. Then again, nothing else is really being called at the exact same moment as Wikipop, so it’s hard to say if that’s actually the issue.

    In any case, the problem results from the fact that Wikipop performs the animation at the same time that it’s loading the Wikipedia page into the frame. I experimented briefly with loading the page content when you rolled your cursor over a link, so it would already be loaded when you actually clicked the link. It did sort of work, but it would also be terrible practice from a UI perspective.

    GimliGlider

    (@gimliglider)

    But it only happens in Mozilla Firefox. And it never happens in any versions of Opera, Safari, Chrome or anything u throw at it LOL

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: WikiPop] I’ve been observing a problem with the animation of Wikipop’ is closed to new replies.