Support » Plugin: Wiki » [Plugin: Wiki lite] style.css not loading on front end editing

  • Hi,
    thank you for this interesting plugin. I’ve been playing with it a little. I’ve noticed that the style.css wasn’t loading on front end editing. So i dived into the source code.

    In /wp-content/plugins/wordpress-wiki-plugin/wiki.php, function output_css on line 1342, i think you should have :
    echo '<link rel="stylesheet" href="' . plugins_url('wordpress-wiki-plugin/css/style.css') . '" type="text/css" />';

    instead of :
    echo '<link rel="stylesheet" href="' . plugins_url('wiki/css/style.css') . '" type="text/css" />';

    because the plugin folder is not named ‘wiki’ but ‘wordpress-wiki-plugin’.

    Bye 😉

    http://wordpress.org/extend/plugins/wordpress-wiki-plugin/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thank you, thank you, thank you imath! You just saved me a world of stress.

    Hopefully they fix this for everyone else! 🙂

    you’re welcome zanzaboonda 😉

    The “wiki” folder is also referenced on line 1271 of wiki.php

    wp_register_script('incsub_wiki_js', plugins_url('wiki/js/wiki-utils.js'), null, $this->current_version);

    … and I just checked the README file and the instructions page on WPMUDEV page. Both reference a /plugins/wiki/ folder. I’m guessing that they changed the named of the folder in the download to differentiate between the lite and premium versions.

    It might be easier to just change the folder name from wordpress-wiki-plugin to wiki.

    We will be getting the folder name issues fixed in the next release with few more changes.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Wiki lite] style.css not loading on front end editing’ is closed to new replies.