WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Widgets Logic Visual] Widgets no longer expand after WP 3.5 upgrade

[Plugin: Widgets Logic Visual] Widgets no longer expand after WP 3.5 upgrade

  • databell96
    Participant

    @databell96

    Just upgraded to WP 3.5 and if Widget Logic Visual 1.52 is turned on and I go to Appearance–>Widgets I no longer can expand my widgets to view their settings. Anyone from the teem here can comment on when that might be fixed?

Viewing 13 replies - 1 through 13 (of 13 total)
  • relaxedguy
    Member

    @relaxedguy

    Similar problem here. Can’t expand widgets to view settings, widgets run fine and widget logic works fine.

    Running JS debug in Chrome I see load-scripts.php throws error:

    Uncaught Error: syntax error, unrecognized expression: #widget-logic-options-adrotate_widgets-%i%.

    Wasn’t sure if it was ad rotate or widget logic. Really don’t want to disable both on my live blog, thought it worked on my staging server.

    melster777
    Member

    @melster777

    yeah mine too.. all of the site that i am developing my boss upgraded it into 3.5 with out asking me.

    all the widgets now is not showing when

    here is the error I got it from firefox

    Timestamp: 12/12/2012 6:28:57 PM
    Error: TypeError: c(…).data(…) is undefined
    Source File: http://davisstibor.strongerbranch.com/wp-content/plugins/black-studio-tinymce-widget/black-studio-tinymce-widget.js?ver=1.0.0
    Line: 1

    Please help

    quantaweb
    Participant

    @quantaweb

    I just upgraded my site to WP 3.5 and have the same issue – can’t move or expand widgets. Really desperate to figure out what to do here as I urgently need to change some widgets/ads.

    quantaweb
    Participant

    @quantaweb

    OK, I may have an answer (at least for some of us). This morning I updated to WP 3.5. After doing so, none of my widgets would expand, couldn’t move widgets to and from the sidebar, etc. Same problem you had.

    But I found the solution (for me anyway):

    Bulletproof Security puts an .htaccess in the wp-admin folder that will prevent widgets from working correctly in 3.5.

    Here’s the link where I found that info: http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

    Delete the .htaccess file in your wp-admin folder and all will be well. (At least it worked for me.)

    my widgets wouldnt open either and this worked for me :

    1. Be sure you are on the widget page
    2. Append ?widgets-access=on to the end of your url.
    3. Enter

    The above forced enable-accessibility to be turned on.

    I hope this helps.

    relaxedguy
    Member

    @relaxedguy

    Kataya that worked for me but now when I click “Edit widget” it opens a new page. At least it works for now. Thank you.

    databell96
    Participant

    @databell96

    Kataya, it worked for me as well. Sneaky trick although I’ll be happier when the developers do an upgrade, of course. Thx.

    socialmoguls
    Member

    @socialmoguls

    Hi, I have the same problem. I am part of a very small nonprofit we do everything ourselves and I am no wp expert. is it possible that someone can fix this problem for me. My wp widgets are disabled. Can someone tell me where to find this file .htaccess. Or is someone wiling to do this for me? If so please email me at sekai@socialmoguls.org thanks!

    socialmoguls
    Member

    @socialmoguls

    I think my issue is java script there is some error that says jQuery error script. Thanks

    khan.shabnam
    Participant

    @khanshabnam

    FIX

    Add following code on line number 58 (in widget_logic_visual_admin_enqueue_script() function)

    wp_register_script('jquery.1.7' ,plugin_dir_url(__FILE__).'js/jquery-1.7.1.min.js');
    
    wp_enqueue_script('jquery.1.7');

    and upload jquery1.7.1.min.js in plugin js folder
    And it works fine for.

    controler
    Member

    @controler

    I’ve added the lines of jquery 1.7.1 but now not work the “edit limitation” button

    Windward19
    Member

    @windward19

    The solution posted by sdaveCL worked for me, from this thread. It’s on the first page, near the bottom. Don’t forget to clear your cache after you’ve updated the code.

    http://wordpress.org/support/topic/stops-working-on-35?replies=36

    @katya77 Thanks that worked!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Widgets Logic Visual] Widgets no longer expand after WP 3.5 upgrade’ is closed to new replies.