Support » Plugin: Widget Settings Importer/Exporter » [Plugin: Widget Settings Importer/Exporter] Import from 3.3.1 into 3.2.1 not working?

  • Resolved Curtiss Grymala


    I have 3 versions of the same WordPress Multisite installation set up (development, staging and production). At the moment, the production site is running WordPress 3.2.1, while the development and staging sites are running 3.3.1. Exporting from development and importing into staging (3.3.1 to 3.3.1) worked just fine, but exporting from staging into production (3.3.1 to 3.2.1) did not. The plugin reported that the import was successful, but all of my widgetized areas are still empty.

    Do you have any idea why this issue might be occurring? Any thoughts on ways I might be able to get the import working? The site I’m trying to import from staging into production is using quite a few widgets, and it would be awesome if I could just import the settings rather than having to manually set up all of the widgets again. Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Kevin Langley Jr.


    I apologize that it’s breaking between versions. This is not something I tested for, but I can definitely see the value in it. I don’t have time today, but within the next couple of days I can take a look and try to get a new version released with this feature. If you don’t have a couple of days to wait, you could grab all rows with their option_name starting with ‘widget_’ and also the ‘sidebars_widgets’ option as well from the same table and just manually import those, very carefully of course. Not really suggested, but it is an option if you don’t have a few days to wait.

    I totally understand. You have nothing to apologize for.

    For this particular application, I did end up exporting rows from one database and importing into the other, but it would still be helpful to be able to do this for other applications in the future (since I expect the versions between our development/staging/production servers to often be different).

    If you don’t get around to it, it’s no big deal; but I just wanted to make you aware of the issue. Let me know if you need any help testing or trying to adjust things. Thanks.

    Plugin Author Kevin Langley Jr.


    Is there any chance you could send me the two files and let me know which one is from 3.2 and which is from 3.3?

    My email address is

    After running a diff between the two files and seeing that there were no substantial differences between them, I decided to try again.

    It turns out this is more of an interface error than an issue with the plugin not working. When I saw the green banner that said “All your widget settings have been imported…”, I clicked the “Widgets” item in the admin menu to visit it, rather than waiting for the plugin to automatically redirect. Apparently the plugin doesn’t actually successfully import the settings until after the green banner appears; so when I clicked the link to manually go to the Widgets page, it hadn’t finished what it was doing yet.

    When I tested a few minutes ago and actually let the plugin redirect automatically, the settings imported correctly.

    Sorry for the erroneous error report (I know how frustrating those can be to track down), and thanks again for this awesome, time-saving plugin.

    Plugin Author Kevin Langley Jr.


    Not a problem at all, I’ll still look into the green confirmation box appearing before it’s finished, but definitely glad to hear it worked still!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Widget Settings Importer/Exporter] Import from 3.3.1 into 3.2.1 not working?’ is closed to new replies.