Support » Plugin: Widget Logic » [Plugin: Widget Logic] (In)Compatibility with Rockettheme’s rokmenu widget

  • I am using the moxy theme from rockettheme and using their excellent rokmenu widget.

    However when I activate your plugin I get the following error:

    Fatal error: Cannot create references to/from string offsets nor overloaded objects in /Users/***/Sites/szd-new/wp-content/themes/rt_moxy_wp/includes/widgets/rokmenu_wget.php on line 137

    Line 137 is:
    $widget =& $widget_info['callback'][0];

    (I’m not including more as not to violate any rockettheme terms & conditions)

    I have contacted rocketthemes already but I thought maybe you might know why this is happening.

    http://wordpress.org/extend/plugins/widget-logic/

Viewing 1 replies (of 1 total)
  • Plugin Contributor alanft

    (@alanft)

    Very hard for me to troubleshoot against code I can’t see, so sorry I can’t really do this for you.

    i can give you pointers by explaining what widget logic does to registered widgets esp wrt ‘callback’ which is:

    the value of the widget data ‘callback’ (a function name) is copied to a new array item called ‘callback_wl_redirect’, and then ‘callback’ is set to ‘widget_logic_redirected_callback’.

    The other thing WL does, which is usually the source of incompatibilities – but doesn’t appear to be in this case – is that it pushes the widget’s id into the widgets ‘params’ array

    hope that gives you something to work on.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Widget Logic] (In)Compatibility with Rockettheme’s rokmenu widget’ is closed to new replies.