Support » Plugin: Widget Context » [Plugin: Widget Context] Can't "target by URL"

Viewing 15 replies - 1 through 15 (of 28 total)
  • I am having the same issue, did you find a resolution?

    No, I haven’t found a solution as yet with my WP 3.4.2 installation. I’ve tried every way of entering the path, but nothing works. It’s a pity because if it wasn’t for this bug it would be an extremely useful plugin.

    If the “target by URL” ever did work, then you would have thought that the code could be brought up to date.

    I made a little progress getting ‘target by URL’ to work, though it doesn’t make sense:

    To hide a widget on the “/relating/” page I used the string “relating”.

    Theory: Initial and final slashes need to be omitted when hiding by URL

    I’m having the same issue – can’t target by URL, with or without slashes. This is probably the one option I’d be using the most; if there’s a fix I’d be grateful to hear it. Targeting by single page has worked temporarily for me, but I’d like to have more control.

    @kelek – Your suggestion works! To hide a widget from my category “books” I type in the “or target by URL” box:

    category/books

    without leading or trailing slashes – and the widget in question now does not show in that category!

    I thought I’d tried every combination, but obviously I missed that one. Thanks!

    I find you can also exclude further pages of the category by (e.g.):
    category/books/page/2

    I want to show on select urls. I’m not able to make that happen nor find specific directions. Do I want to check any of the boxes on the left?

    I want to specify a specific page (not category or post)
    This site was moved from a different server where the plugin was working. The widget is the text widget. The target url is the full path (not changed with the server move).

    Any help is appreciated.

    Never mind, after I saved several times it started working one by one. I did have to change from the full path to just the page and no slash.

    Doesn’t work no matter what combo I try. This would be really helpful if it worked. Do I need to set any category settings in addition to configuring the widget URL and such?

    I put a little debug line into widget-context.php to echo $url; just before the return from function get_current_url()

    On my local site it showed https://localhost/mypage

    Not at all what I was expecting, but using that string gets a match on target by URL.

    Better still…seems you can use the * wildcard anywhere on the URL.

    e.g. */mypage/*

    Hope that helps.

    Make sure you don’t have an empty carriage return in “or target by URL” field.

    I found *category/mycategory* works

    but any other varient doesnt’ seem to work ie. /category/mycategory* or /category/mycategory/*

    It seems like it works, but is a bit too picky (and the examples given in the plugin itself don’t work)

    It worked for me when i entered the page like this:

    no checkbox clicked

    url: xxx.com/some-name-of-page/

    i used: */some-name-of-page

    notice there is no end slash

    I’ve found the solution that worked for me. To use this you have to first set the wordpress permalinks under ‘Settings – Permalinks’. Use Custom Structure e.g. /%category%/%postname%/ which means your permalinks or URL (using an example of a category called ‘events’) will look like this:

    Category index pages: http://abc.com/category/events/
    Post pages: http://abc.com/events/public-stoning-on-monday/

    Settings for this widget can thus be:

    category/events (for the events index page)
    events/* (for all pages under the category events)

    Hope that helps.

    Just Type in the page without any other markup like this ==>> mobile-website-design No / or any symbols.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘[Plugin: Widget Context] Can't "target by URL"’ is closed to new replies.