Support » Plugin: Websimon Tables » [Plugin: Websimon Tables] plugin not working with wp v_3.3.1

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author websimonr



    I´ll will check that as fast as I can. I´ve tried it succesfully with 3.3.1 but I will check some things anyway!

    Thanks for your post.


    Plugin Author websimonr


    I´ve updated the plugin. This will probably help you.

    thank you!

    Hi there

    Awesome plugin – great work.

    It was working beautifully for me and then all of sudden (after successfully creating 10 tables) it stopped working properly. The design is no longer showing both in the table creation area and on my site. The old table designs are still working, but I cannot create new ones for the site.

    What has happened? I have not installed any other plugins during this time or changed anything about the site. I was only in the middle of creating another table. I’ve tried deleting and starting over again, copying another table and trying to edit that – all options don’t work. The designs of new tables are no longer showing.

    I’m using WordPress 3.3.2


    Plugin Author websimonr


    Hi Dan
    Which version of the plugin are you using? Did you update anything in your installation?

    It´s a bit strange that it stopped working without you changing anything.

    Hey, I absolutely love your plugin! Kudos!

    I have a question: is it possible to show the titles in the table vertically, like those 3 tables here: ?

    I hope you can help me, because I have a lot of rows and when I can’t get them vertically it doesn’t fit on my webpage 🙁

    Plugin Author websimonr


    Hi jordyfranken, those vertical titles are images. You can do the same thing in the plugin, just add img tags in the headlines.

    Ah, thanks! You’re right! Last question: is it possible to merge cells with each other?

    Plugin Author websimonr


    Hi, currently there is no support for merging cells in the plugin. There has been quite alot of questions about that feature and I´ll check if it is possible to add that. The plugin was not really built for more advanced features but I´ll definitely give it a try 😉

    Hi there!

    Thanks for the awesome plug-in!

    I too am having a problem where one of my tables stopped functioning properly. My table is 9 rows with 2 columns. For some reason the second row isn’t shown on either the back-end or front-end, and any new rows that I add don’t show up either. Any ideas?

    Thanks in advance!

    Plugin Author websimonr


    Hi lognerd, it sounds a little bit like you have som html markup in your table that might be causing that.

    Does other tables or if you create a new one work?

    Thank you for such a wonderful plugin; however, the plugin is only available to Administrators on our websites. Do you have a work around for that?
    As fast as I asked the question, I found the answer. I installed the “User Role Editor” plugin and checked the “manage_options” selection to my contributor/author/editor roles and viola. This isn’t the best option as it makes the Settings menu available as well, but it will work for now. I will just remind everyone to stay out of that area. Thanks for all your efforts!

    I found an even better solution. I edited part of your websimon_tables.php file to add the submenu for any users who have “read” access by replacing the ‘manage_options’ line with ‘read’ as shown here:

    //Add a submenu page
    function websimon_tables_menu_items() {
    	add_submenu_page( 'tools.php', 'Websimon Tables', 'Websimon Tables', '<strong>read</strong>', 'websimon_tables', 'websimon_tables_plugin_page');
    *	function that displays all admin pages
    function websimon_tables_plugin_page () {
    	if (!current_user_can('<strong>read</strong>'))  {
    		wp_die( __('You do not have sufficient permissions to access this page.') );

    This allows access to your plugin without displaying the Settings menu in the dashboard for authors, editors, etc. Sorry to hijack this thread and thanks again.

    [Moderator Note: Please post code or markup snippets between backticks or use the code button. As it stands, your code may now have been permanently damaged/corrupted by the forum’s parser.]

    Plugin Author websimonr


    Hi jdeems

    Your at exactly the right place to edit the capabilities. You should probably remove the strong tag and just have “read”

    For more roles and capabilities please check:



    Hi WS:

    Great plug-in. It took some time to build but looks great with the hover effect.:

    The only thing I found was it would be nice to justify and set type parameters for individual rows and or columns ir individual cells. I have entered some CSS parameters to try and correct type issues, but am struggling with getting the image in the upper left of each to sit properly as I cannot “format” just that cell.

    Great job and hoping you can keep up the great work. It’s plug-ins like yours that make WP easy to use.


Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Websimon Tables] plugin not working with wp v_3.3.1’ is closed to new replies.