WordPress.org

Support

Support » Plugins and Hacks » Web Ninja Google Analytics » [Resolved] [Plugin: Web Ninja Google Analytics] Significant delay in dashboard view posts/pages

[Resolved] [Plugin: Web Ninja Google Analytics] Significant delay in dashboard view posts/pages

Viewing 9 replies - 1 through 9 (of 9 total)
  • I disabled the per-post analytics charts …

    http://wordpress.org/support/topic/plugin-web-ninja-google-analytics-edit-posts-page-delay

    … but I am still seeing this kind of delay on the dashboard.

    Is there any way to disable or cache the analytics block on the dashboard?

    I’m sorry to say the delay is so slow, I’ve temporarily switched to another plugin.

    But, as soon as caching is implemented, I’ll be back. I really like the charts!

    Seems like it gets slower and slower too… or maybe it’s my tolerance.

    I love the charts too — great idea, fantastic plugin if you’ve got some time on your hands… otherwise, not quite ready for prime time.

    This is a great plugin (GA of choice : )

    But….Not sure why but the dashboard fails to load all incoming ‘feeds’ and actually prevents me from moving/arraning the admin modules.

    I’ve had the same issue with the plugin on a recent install – even though it has worked flawlessly on other installs.

    I’ve tried activating/deactivating to no avail.
    Can this be attributed to a buggy install?

    Thanks for your help!

    Anybody know the status on this? I am getting warning messages that it is timing out and cannot connect. The forum seems to be shut down. I have sent emails, posted on Web Ninja’s fan page at FB and am getting no response.

    I’m afraid if I deactivate, I’ll lose all my GA Analytics & I am not techie enough to understand how to add the tracking to every page-which is why I got the plugin in the 1st place.

    Thanks for any help/

    Since the issues haven’t been resolved, at least with WP 3.0.5, I permanently switched to the Google Analytics for WordPress plugin, which inserts tracking code into every page.

    Also, your data is stored in your Google Analytics account, so you will not lose anything by switching plugins.

    @jcollier-thanks so much for the help. This non-techie really appreciates it. 🙂

    My pleasure!

    Plugin Author joshfowler

    @joshfowler

    Hello everyone, I am sorry in the delay in getting back to everyone. Things have been recently busy for me. But I am about to update the plugin with a few fixes. Also, the delay in the plugin in the dashboard and post/page admin pages actually isn’t due to the plugin but the downloading of data from Google Analytics for your stats. The more traffic you get the more data it has to download. There are a few ways to help it.

    1. Only have it display the last 7 days so it’s not downloading data from the last 30 days.
    2. Change your “Cache Timeout” in the options. Right now it is set to 60 seconds. That means every minute it is going to download data from Google. Unforunately, there is no way with their API to download partial data. Really, you can only download all the data each time. So, if you set the cache timeout to download every 3600 seconds it will only download the data hourly instead of every minute.
    3. Disable the page/post stats. When it downloads the data for post and pages it has to download the data for each page and post. If you have a lot of post or get a lot of traffic this could take a while for the site to download all that data. If you don’t want to wait for the data to download you could disable the stats on the post and page admin pages.

    I hope this helps some.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] [Plugin: Web Ninja Google Analytics] Significant delay in dashboard view posts/pages’ is closed to new replies.
Skip to toolbar