Support » Plugin: WassUp Real Time Analytics » [Plugin: WassUp] Fatal error

  • Wassup was working just fine with WP 3.1, until I deactivated it and then tried to activate it again. Then I got a fatal error. Anyone know how to fix it? Wassup is the best WordPress analytics plugin I’ve seen and I want it back.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You may want to take a look at this alternative analytics plugin:


    Plugin Contributor helened


    There is a subtle typo in Wassup 1.8.1 install script that could have triggered this error. To fix, go to WordPress plugins menu, click on Editor submenu, select plugin to edit:“WassUp” in the drop-down box at right, find line #145: “remove_option(‘wassup_settings’);” in the “wassup_install()” function, it is below the final “else” statement in the function, just below the comment ‘//main table not created – exit with error’. Replace “remove_option” with “delete_option”, and click [Update File] to save. Then try activating WassUp in Plugins. Good luck!

    Thanks for the replies. I tried fixing the typo in the Wassup install script, but I still get a fatal error when I try to activate it. Is there anything else I could try?

    Plugin Contributor helened


    Sorry the previous fix didn’t work.

    There is another fix that you can try that completely bypasses the upgrade script to update WassUp’s tables. Since WordPress 3.0, the ‘dbDelta’ function sometimes chokes on WassUp’s large table structure and that can also cause activation failure due to a MySql ‘ALTER table’ error. You’ve already upgraded WassUp’s table, so there is no need to do it again.

    To bypass, go to WordPress plugin editor, select “wassup.php” and comment out line #116: $success = wassup_tableInstaller(); inside the “wassup_install()” function, i.e, prepend the characters, // to the beginning of the line.

    Good luck.

    That worked, thanks!



    Of course I’m not certain if that solves the problem. You just skip the warning, I think!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: WassUp] Fatal error’ is closed to new replies.