Support » Plugins » [Plugin: W3 Total Cache] wp-content/w3tc/min/default.include.css not present, 500 error

  • I am using WordPress 2.8.6 and W3 Total Cache version 0.8.5. I added one stylesheet with full URI to the minify settings and saved, then cleared the cache. When I reloaded the home page of the site, it was apparent the stylesheet was missing. I checked the source of the page, and I saw this:

    <link rel="stylesheet" type="text/css" href="" media="all" />

    in the <head> element, but when I try to access that page, I get a 500 server error.

    If I look in the filesystem, that default.include.css file is not present. When I remove the stylesheet from the minify settings, the site goes back to normal.

    It appears that W3 Total Cache is working perfectly for almost everything else on the site, but I cannot get this to work for the life of me. Any tips you can provide are appreciated.

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Are any CSS files you’re using 3rd Party or generated dynamically? If so that is likely to be the problem. If not, see if you can check the .log file in w3tc/min/ and see what the error message is?

    Hi, I just noticed the same thing happening. Both with css and js files that I added to be minified… I tried with just one, and many (even a dynamic one) combined in header or footer, all resulting in the same thing: 500 internal server error from the /wp-content/w3tc/min/default.include.css/js location.

    Then I tested with a subdomain with FTP access set up in CDN. On the FTP server, a new /wp-content/w3tc/min/default.include.css and .js created but when I download these files, instead of packed js or css, they contain the source code of that same 500 internal server error message!

    The debugging option does not report anything wrong. I searched for a .log file in the /wp-content/w3tc/min/ dir but there is none… Anything more I can do to find out what is happening? Would a phpinfo() be helpful?

    Can you submit a bug submission on the support tab of the plugin with access to your server? Otherwise there’s not enough information to investigate.

    Ok, will do…

    I have found that if I comment out the line
    RewriteRule ^([a-z0-9-_]+)\.(include(-footer)?(-nb)?)\.(css|js)$ index.php?gg=$1&g=$2&t=$5 [L] at the end of the .htaccess in the /wp-content/w3tc/min/ folder, the 500 internal server error becomes a 404 not found error. This would be consistent with the fact that the rewrite is no longer taking place. To see if the .htaccess rule was causing the problem on my shared server, I tried to talk to the index.php file directly by visiting the URL mydomain.tld/wp-content/w3tc/min/index.php?gg=default&g=&t=js and it returned the 500 error…

    It is just too bad my provider does not have error log files for hosting accounts 🙁

    Ah, no, I was too hasty in my conclusion. I did that last test (calling index.php directly) with the last rewrite rule active… When I did the same with the rewriterule commented out again, I got a HTTP/1.0 400 Bad Request response from index.php.

    Does this tell you anything?

    No it doesn’t, because this functionality is well tested and widely deployed. There’s something unique to your case that I can only find with a bug submission report.

    Thanks Frederick, your new version 8.5.1 fixes the 500 error for me: zlib.output_compression was running on my server space! The new warning on the W3TC settings page made me turn it off via a php.ini file containing

    zlib.output_compression = Off

    in my site root and now (after de- and re-activating the plugin) the include files are created!

    If this were my thread, I’d mark it solved 🙂

    [ Another problem with the .htaccess has surfaced now but I have mailed you about it since I do not want to clutter this topic with new only slightly related (?) problems… ]


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: W3 Total Cache] wp-content/w3tc/min/default.include.css not present, 500 error’ is closed to new replies.