WordPress.org

Forums

[Plugin: W3 Total Cache] WordPress Upgrade (15 posts)

  1. fkranjce
    Member
    Posted 5 years ago #

    Just wanted to ask if there are some specific steps to do during upgrade to new WordPress version.

    W3 total cache have to be disabled before or it can stay enabled?

    Some other things to make sure of before upgrade is started?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Posted 5 years ago #

    Actually the upgrade was made available in error. A single line in readme.txt was incorrect. Only the development version is updated: http://wordpress.org/extend/plugins/w3-total-cache/download/ - upgrading always requires deactivation and reactivation.

  3. ishan001
    Member
    Posted 5 years ago #

    And I have upgraded! Now, should I wait for actual upgrade or downgrade? I am having problems with CDN. To be exact, all the cloudfront settings are there but plugin is displaying a big banner at top of admin pages saying: Content Delivery Network Error: The "Access key", "Secret key", "Bucket" and "Replace default hostname with" fields must be populated.
    And strangely, CDN is working for some images(i.e. plugin is updating urls for only some images!) and others are being served from own server. Isn't plugin supposed to rewrite all URLs?

  4. ishan001
    Member
    Posted 5 years ago #

    And yes, I'm using WP 3.0!

  5. Frederick Townes
    Member
    Posted 5 years ago #

    What version to run is up to you. There are bugs with S3/Cloudfront with v0.8.5.2 that are hopefully resolved in v0.9.

  6. ishan001
    Member
    Posted 5 years ago #

    Just noticed that it works fine! Only the error is displayed and everything else works great!

  7. Frederick Townes
    Member
    Posted 5 years ago #

    Please upgrade to the latest development version and confirm if the error is gone.

  8. ishan001
    Member
    Posted 5 years ago #

    Noticed this a bit late. I am traveling today, will upgrade today.

  9. Frederick Townes
    Member
    Posted 5 years ago #

    Ok.

  10. ishan001
    Member
    Posted 5 years ago #

    Nope, the message is still there. I downloaded latest version. It says it is version 0.9

  11. Frederick Townes
    Member
    Posted 5 years ago #

    Distribution value is set?

  12. ishan001
    Member
    Posted 5 years ago #

    Yes, every value is set. In fact, plugin is working great with CDN and images are being served from CDN, it's just the message that remains there!

  13. Frederick Townes
    Member
    Posted 5 years ago #

    Seems there's an issue saving your configuration settings. If you want you can submit a bug submission form.

  14. ishan001
    Member
    Posted 5 years ago #

    Recent upgrade to final 0.9.0 fixed everything!

  15. Frederick Townes
    Member
    Posted 5 years ago #

    Great.

Topic Closed

This topic has been closed to new replies.

About this Topic